Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 29 Dec 1995 21:05:37 -0500 (EST)
From:      Barry Masterson <jbarrm@panix.com>
To:        "freebsd.questions" <questions@freebsd.org>
Subject:   ppp from shell, & starting X
Message-ID:  <Pine.SUN.3.91.951229205315.2927A-100000@panix.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello,
I hope this is a simple question.

When I'm in the shell (csh text display), and run iijppp from a
freshly booted system, I get the following message (below is a sample 
from past log entries):

Dec 17 08:59:50 /kernel: rtinit: wrong ifa (0xf054e500) was (0xf04dee00)
Dec 18 11:22:24 /kernel: rtinit: wrong ifa (0xf051fe00) was (0xf04dee00)
Dec 28 21:12:12 /kernel: rtinit: wrong ifa (0xf04ebc80) was (0xf04dee00)
Dec 29 17:06:01 /kernel: rtinit: wrong ifa (0xf053f680) was (0xf04dee00)

At this point I simply close & quit PPP, and restart PPP.  Then all is
well. ncftp, lynx, pine, gopher, irc, rlogin, telnet, archie, all work.
In fact, I can close & quit, & restart ppp again & again.  Its not until
I reboot the system and run ppp that the 'rtinit' message appears again. 

Any processes I try to run while in this 'first-run' ppp mode Won't
work.  This is not really a problem by itself (simply Close & Quit &
restart ppp) 
But, when I finish with ppp (csh text shell), and try to 'startx', I 
get the following message:


TRANS(SocketUNIXConnect) () can't connect: errno = 61

waiting for X server to begin accepting connections .
TRANS(SocketUNIXConnect) () can't connect: errno = 61
..
TRANS(SocketUNIXConnect) () can't connect: errno = 61
..TRANS(SocketCreateListener): failed to bind listener
TRANS(SocketINETCreateListener): TRANS(SocketCreateListener) () failed
TRANS(MakeAllCOTSServerListeners) failed to create listener for tcp

Fatal server error:
Failed to establish all listening sockets

TRANS(SocketUNIXConnect) () can't connect: errno = 61
giving up.
xinit:  Connection refused (errno 61):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.


Xwindows won't run After I've run ppp (from csh text shell). To run X, I 
have to reboot, Then startx works without any problems. Again, this is
not really a problem, just annoying, having to reboot everytime I want
to startx after a ppp session.
 ( 'kill -1 1'  &  'kill -HUP 1'  doesn't solve this problem ) 

So my first question is, Does the rtinit message have anything to do
with my Not being able to startx after running ppp from the text shell?
And of course, how can I solve this problem?

My second question has to do with running ppp from Xwindows. Currently
I have the ppp files in /usr/sbin, so, to run ppp, I run it as root.
Not a problem from the shell, I've got all of those vc's.

However, I want to run X, ppp & netscape as a normal user. (ppp & netscape
work fine if I startx as root).

Question 2: Can I simply place the ppp files:

     /usr/sbin
     -r-sr-xr-x  1 root  bin   86016 Nov 16 04:57 ppp
     -r-sr-xr-x  1 root  bin   61440 Nov 16 04:57 pppd
     -r-xr-sr-x  1 bin   kmem  12288 Nov 16 04:57 pppstats
	
in my ~/home/bin  directory, and expect it to run without any complaints.

Thank you

Barry Masterson
jbarrm@panix.com

>--->--->--->--->--->
  FreeBSD     2.1.0       486DX2/66 - 1gig IDE drive - 8meg ram
<---<---<---<---<---<




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?Pine.SUN.3.91.951229205315.2927A-100000>