Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 30 Jun 2011 08:21:29 -0700
From:      Devin Teske <dteske@vicor.com>
To:        Warren Block <wblock@wonkity.com>
Cc:        freebsd-questions@freebsd.org, Dieter BSD <dieterbsd@engineer.com>
Subject:   Re: Attempting to get an X11 server running
Message-ID:  <A15B9AD3-FB6A-4AF7-8B61-7A5CBCA7A368@vicor.com>
In-Reply-To: <alpine.BSF.2.00.1106300706350.33308@wonkity.com>
References:  <20110630001249.219420@gmx.com> <alpine.BSF.2.00.1106300706350.33308@wonkity.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

On Jun 30, 2011, at 6:11 AM, Warren Block wrote:

> On Thu, 30 Jun 2011, Dieter BSD wrote:
>=20
>> google found
>> http://www.daemonforums.org/showthread.php?p=3D27601
>> which suggests using moused instead of hald.  moused runs,
>> but I think I have to get Xorg to use a config file to set
>>  Option "AllowEmptyInput" "off"
>>  Option "AutoAddDevices"  "off"
>> so that it will work without hald.
>=20
> That is incorrect.  Don't set AllowEmptyInput, just turn off AutoAddDevic=
es.
> http://www.wonkity.com/~wblock/docs/html/aei.html
>=20
>> Question 1: why does "Xorg -configure" create a config file
>> that doesn't work the same way as just running "Xorg" ?
>=20
> The defaults assumed when run are different from those in the generated c=
onfig file.  I don't know why.
>=20
>> Question 2: how do I get a usable config file?
>=20
> Look for examples on the net.  Realize that most of xorg.conf is optional=
 now, and you can leave out sections where the defaults are correct.
>=20
>> Question 3: how do I get complete modeline info for what
>> it is currently running?
>=20
> Please don't mess with modelines, it should not be needed any more. Just =
set the resolutions desired in the Screen/Display section.  If modelines ar=
e really required, get them out of /var/log/Xorg.0.log.  But they almost ce=
rtainly are not.

Though if you *really* wanted to, there's cvt(1):

cvt - calculate VESA CVT mode lines


>=20
>> Question 5: how do I get hald to work?
>=20
> It's not used if you turn off AutoAddDevices or build the xorg-server por=
t with the HAL option disabled.____________________________________________=
___
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.o=
rg"

--=20
Cheers,
Devin Teske

-> CONTACT INFORMATION <-
Business Solutions Consultant II
FIS - fisglobal.com
510-735-5650 Mobile
510-621-2038 Office
510-621-2020 Office Fax
909-477-4578 Home/Fax
devin.teske@fisglobal.com

-> LEGAL DISCLAIMER <-
This message  contains confidential  and proprietary  information
of the sender,  and is intended only for the person(s) to whom it
is addressed. Any use, distribution, copying or disclosure by any
other person  is strictly prohibited.  If you have  received this
message in error,  please notify  the e-mail sender  immediately,
and delete the original message without making a copy.

-> END TRANSMISSION <-

_____________

The information contained in this message is proprietary and/or confidentia=
l. If you are not the intended recipient, please: (i) delete the message an=
d all copies; (ii) do not disclose, distribute or use the message in any ma=
nner; and (iii) notify the sender immediately. In addition, please be aware=
 that any message addressed to our domain is subject to archiving and revie=
w by persons other than the intended recipient. Thank you.
_____________



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?A15B9AD3-FB6A-4AF7-8B61-7A5CBCA7A368>