Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 22 Nov 2013 19:51:51 +0100
From:      vermaden <vermaden@interia.pl>
To:        freebsd-questions@freebsd.org, freebsd-stable@FreeBSD.org, freebsd-current@freebsd.org
Subject:   FreeBSD 10-BETA3 - zfs clone of zvol snapshot is not created
Message-ID:  <klgmmtyeaujlwrhwpost@wvbm>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

am I doing something wrong, ZFS does not support that or there is a bug that zvol clone does not show up under /dev/zvol after creating it from other zvol snapshot?

# zfs list -t all | grep local
local                                     136G  76.8G   144K  none
local/home                                117G  76.8G   117G  /home
local/vm                                 18.4G  76.8G   144K  none
local/vm/vbox_pcbsd_10                   5.35G  76.8G  5.35G  -
local/vm/vbox_windows_7                  10.8G  76.8G  9.86G  -
local/vm/vbox_windows_7@clean             940M      -  8.12G  -
local/vm/vbox_windows_xp                 2.27G  76.8G  2.16G  -
local/vm/vbox_windows_xp@clean            109M      -  1.07G  -

# zfs clone local/vm/vbox_windows_7@clean local/vm/vbox_windows_7_personal

# zfs list -t all | grep local
local                                     136G  76.8G   144K  none
local/home                                117G  76.8G   117G  /home
local/vm                                 18.4G  76.8G   144K  none
local/vm/vbox_pcbsd_10                   5.35G  76.8G  5.35G  -
local/vm/vbox_windows_7                  10.8G  76.8G  9.86G  -
local/vm/vbox_windows_7@clean             940M      -  8.12G  -
local/vm/vbox_windows_7_personal            8K  76.8G  8.12G  -
local/vm/vbox_windows_xp                 2.27G  76.8G  2.16G  -
local/vm/vbox_windows_xp@clean            109M      -  1.07G  -

# find /dev/zvol 
/dev/zvol
/dev/zvol/local
/dev/zvol/local/vm
/dev/zvol/local/vm/vbox_pcbsd_10
/dev/zvol/local/vm/vbox_windows_7
/dev/zvol/local/vm/vbox_windows_7@clean
/dev/zvol/local/vm/vbox_windows_xp
/dev/zvol/local/vm/vbox_windows_xp@clean
/dev/zvol/local/vm/vbox_pcbsd_10p1
/dev/zvol/local/vm/vbox_pcbsd_10p2
/dev/zvol/local/vm/vbox_windows_7@cleans1
/dev/zvol/local/vm/vbox_windows_xps1
/dev/zvol/local/vm/vbox_windows_xp@cleans1

... the missing clone:
/dev/zvol/local/vm/vbox_windows_7_personal

Regards,
vermaden



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?klgmmtyeaujlwrhwpost>