Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 09 Nov 2015 11:44:19 -0800
From:      David Christensen <dpchrist@holgerdanske.com>
To:        freebsd-questions@freebsd.org
Subject:   FreeBSD-10.2-RELEASE-amd64 encrypted ZFS root and swap
Message-ID:  <5640F793.2020008@holgerdanske.com>

Next in thread | Raw E-Mail | Index | Archive | Help
freebsd-questions:

I have a computer:

     Intel D945GTPLKR motherboard
     Intel Pentium 4 640 processor
     4 GB RAM
     Western Digital WD800JB IDE HDD
     Pioneer BDR-206UBK Blu-Ray/DVD/CD RW drive

I have downloaded and burned to CD:

     FreeBSD-10.2-RELEASE-amd64-disc1.iso

When I install BSD as follows:

	Welcome			Install
	Keymap Selection	Continue with default keymap
	Set Hostname		p43200
	Distribution Select	doc
				games
				lib32
				ports
				src
	Partitioning		Auto (ZFS)
	    Pool Type/Disks	stripe: 0 disks
	    Pool Name		zroot
	    Force 4K Sectors	YES
	    Encrypt Disks	Yes
	    Partition Scheme	GPT
	    Swap Size		2g
	    Mirror Swap		NO
	    Encrypt Swap	YES
	    Install
	Virtual Device type	stripe
	<device>		ada0
	Enter passphrase	********
	Root password		********
	Network Configuration
	    Select an interface	em0
	    Configure IPv4	Yes
	    Use DHCP		Yes
	    Configure IPv6	No
	    Resolver Configuration
		Search 		holgerdanske.com
		IPv4 DNS #1	10.7.171.1
		IPv4 DNS #2	<none>
	Select clock		No
	Time zone		America
	Country			United States
	Time zone		Pacific Time
	System Configuration	sshd
				ntpd
				powerd
				dumpdev
	Add User Accounts	No
	Exit
	Shell			No
	Reboot			Reboot

I see the following:

     No bootable device -- insert boot disk and press any key

STFW I see:

 
https://lists.freebsd.org/pipermail/freebsd-questions/2014-March/256568.html

The solution at that time was to use MBR.  Trying again:

	Welcome			Install
	Keymap Selection	Test default keymap -- okay
				Continue with default keymap
	Set Hostname		p43200
	Distribution Select	doc
				games
				lib32
				ports
				src
	Partitioning		Auto (ZFS)
	ZFS Configuration
	Configure Options
	    Pool Type/Disks	stripe: 0 disks
	    Pool Name		zroot
	    Force 4K Sectors	YES
	    Encrypt Disks	Yes
	    Partition Scheme	MBR
	    Swap Size		2g
	    Mirror Swap		NO
	    Encrypt Swap	YES
	    Install
	Virtual Device type	stripe
	<device>		ada0
	Enter passphrase	********
	Root password		********
	Network Configuration
	    Select an interface	em0
	    Configure IPv4	Yes
	    Use DHCP		Yes
	    Configure IPv6	No
	    Resolver Configuration
		Search 		holgerdanske.com
		IPv4 DNS #1	10.7.171.1
		IPv4 DNS #2	<none>
	Select clock		No
	Time zone		America
	Country			United States
	Time zone		Pacific Time
	System Configuration	sshd
				ntpd
				powerd
				dumpdev
	Add User Accounts	No
	Exit
	Shell			No
	Reboot			Reboot

I see a black screen with a blinking cursor.

Any suggestions?

TIA,

David



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5640F793.2020008>