Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 19 May 2012 08:00:58 -0600 (MDT)
From:      Warren Block <wblock@wonkity.com>
To:        Gary Aitken <garya@dreamchaser.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: ATI Radeon HD5500 driver question
Message-ID:  <alpine.BSF.2.00.1205190753560.30455@wonkity.com>
In-Reply-To: <4FB730B7.60009@dreamchaser.org>
References:  <4FB730B7.60009@dreamchaser.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, 18 May 2012, Gary Aitken wrote:

> Trying to set up a new box 9.0-RELEASE w/ X; has ATI Radeon HD5500 card.
>
> X.org -config says:
>  Missing output drivers.  Configuration failed.
>
> From X.org I see one is supposed to get linux drivers from ati/amd,
> but this info is over 2 years old and
>  http://support.amd.com/us/gpudownload/Pages/index.aspx
> only allows choices of drivers for windoze.
>
> Can anyone point me to a useable driver, or if these cards are essentially 
> unusable, make a suggestion for a reliable card suitable for non-gaming (2-D) 
> X work?

The radeon driver wants KMS for cards later than the 4000 series.  A few 
of the 5000 series may somewhat work with the existing UMS driver, but 
most do not.

KMS for Intel video is being worked on and already being used, but AFAIK 
work has not even begun for the Radeons.

> Should one use an Nvidia card with the Linux 295.53 driver?

A Radeon 4650 works fine with the current radeon driver.  The Nvidia 
cards are faster with the FreeBSD version of their proprietary driver,
...but it's a proprietary driver.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1205190753560.30455>