Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 24 Mar 2009 19:24:26 +0100 (CET)
From:      Juergen Lock <nox@jelal.kn-bremen.de>
To:        guru@unixarea.de
Cc:        freebsd-questions@freebsd.org
Subject:   Re: 7.0-STABLE && qemu not terminating
Message-ID:  <200903241824.n2OIOQ4Z068798@saturn.kn-bremen.de>
In-Reply-To: <20090317143537.GA12969@rebelion.Sisis.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
In article <20090317143537.GA12969@rebelion.Sisis.de> you write:
>
>Hello,
>
>My VM qemu (qemu-0.9.1_3 / kqemu-kmod-1.3.0.p11_2) does not terminate 
>after the system (WinXP) is successfully halted and the qemu window is
>closed; it stays forever as:
>
># ps ax | fgrep qemu
> 1687  ??  I      0:00,25 kdesu -u root -c /home/guru/qemu/w2k/qemu.sh 
> 1713  ??  Is     0:00,00 sh -c /home/guru/qemu/w2k/qemu.sh 
> 1714  ??  I      0:00,00 /bin/sh /home/guru/qemu/w2k/qemu.sh
> 1717  ??  DE    11:51,11 qemu -localtime -hda disk0 -hdb disk1 -net nic -net tap -m 512
>
>any ides? thx
>
>	matthias

While I don't remeber seeing reports about this particular issue, it is
still very well possible that it has been fixed in the meantime, so I'd
advise you to update.  (the port is at 0.10.1 now, which contains quite
a few bugfixes and improvements...  Don't forget to read UPDATING and
the pkg-message of the port tho.)

 Oh and also, there usually is no reason to run qemu as root if you setup
tap permissions and (possibly) ifup/down scripts accordingly.  (Or,
if you are only using tuntap because you are on amd64 where slirp was
broken, that also is fixed now.)

 HTH,
	Juergen



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200903241824.n2OIOQ4Z068798>