Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 17 Sep 2014 10:34:38 +0200
From:      Vikash Badal <vikashb@where-ever.za.net>
To:        freebsd-questions@freebsd.org
Subject:   X blank screen with NVIDIA Quadro K1100M on FreeBSD 10.1-BETA1 #26 r271693
Message-ID:  <5419479E.10309@where-ever.za.net>

Next in thread | Raw E-Mail | Index | Archive | Help
Greetings

Can someone provide assistance ?


X starts up with a black ( blank ) screen

/var/log/Xorg.0.log
=======================
[  2140.756] (II) Module ABI versions:
[  2140.756] 	X.Org ANSI C Emulation: 0.4
[  2140.756] 	X.Org Video Driver: 12.1
[  2140.756] 	X.Org XInput driver : 16.0
[  2140.756] 	X.Org Server Extension : 6.0
[  2140.756] (--) PCI:*(0:0:2:0) 8086:0416:1028:060d rev 6, Mem @
0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @
0x????????/65536
[  2140.756] (--) PCI: (0:2:0:0) 10de:0ff6:1028:060d rev 161, Mem @
0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @
0x0000e000/128

[  2140.780] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card
support
[  2140.780] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  2140.780] (==) NVIDIA(0): RGB weight 888
[  2140.780] (==) NVIDIA(0): Default visual is TrueColor
[  2140.780] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  2140.780] (**) NVIDIA(0): Option "UseEdidDpi" "FALSE"
[  2140.780] (**) NVIDIA(0): Option "DPI" "96x96"
[  2140.820] (**) NVIDIA(0): Option "MetaModes" "DFP: 1920x1080 +0+0,
CRT: 1920x1080 +0+0; DFP: nvidia-auto-select +0+0, CRT:
nvidia-auto-select +0+0; DFP: nvidia-auto-select +0+0; DFP:
nvidia-auto-select +0+0; DFP: nvidia-auto-select +0+0; DFP: nvidia-auto
-select +0+0; DFP: nvidia-auto-select +0+0"
[  2140.821] (**) NVIDIA(0): Enabling 2D acceleration
[  2140.974] (II) NVIDIA(0): NVIDIA GPU Quadro K1100M (GK107GL) at
PCI:2:0:0 (GPU-0)
[  2140.974] (--) NVIDIA(0): Memory: 2097152 kBytes
[  2140.974] (--) NVIDIA(0): VideoBIOS: 80.07.b3.00.0c
[  2140.974] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  2140.974] (--) NVIDIA(0): Valid display device(s) on Quadro K1100M at
PCI:2:0:0
[  2140.974] (--) NVIDIA(0):     none
[  2140.974] (II) NVIDIA(0): Validated MetaModes:
[  2140.974] (II) NVIDIA(0):     "NULL"

[  2140.974] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[  2140.974] (**) NVIDIA(0): DPI set to (96, 96); computed from "DPI" X
config option
[  2140.974] (WW) NVIDIA(0): UBB is incompatible with the Composite
extension.  Disabling
[  2140.974] (WW) NVIDIA(0):     UBB.
[  2140.974] (--) Depth 24 pixmap format is 32 bpp
[  2140.974] (II) NVIDIA: Reserving 3072.00 MB of virtual memory for
indirect memory
[  2140.974] (II) NVIDIA:     access.
[  2140.977] (II) NVIDIA(0): Setting mode "NULL"
[  2140.977] (EE) NVIDIA(0): Failed to initiate mode change.
[  2140.977] (EE) NVIDIA(0): Failed to complete mode change
[  2140.986] (II) NVIDIA(0): Built-in logo is bigger than the screen.


pciconfig -lv

vgapci0@pci0:2:0:0:     class=0x030200 card=0x060d1028 chip=0x0ff610de
rev=0xa1
hdr=0x00
    vendor     = 'NVIDIA Corporation'
    class      = display
    subclass   = 3D


There is no option to disable the optimus in the bios
Is there a way do disable from commandline or /boot/loader.conf or sysctl  ?



Thanks
Vikash





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5419479E.10309>