Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 22 May 2015 07:11:29 -0700
From:      Jeffrey Bouquet <jeffreybouquet@yahoo.com>
To:        freebsd-questions@freebsd.org
Cc:        questions@freebsd.org
Subject:   Perl Errors  (v10) perl5-5.20.2_4
Message-ID:  <1432303889.63155.YahooMailBasic@web140902.mail.bf1.yahoo.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Question embedded within the following three build 
failure logs; sorry for the webmail client which does
not show all the test when formulating it...

Script started on Fri May 22 06:39:37 2015
command: make build
===>  Found saved configuration for p5-Module-Signature-0.79
===>   p5-Module-Signature-0.79 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by p5-Module-Signature-0.79 for building
===>  Extracting for p5-Module-Signature-0.79
=> SHA256 Checksum OK for Module-Signature-0.79.tar.gz.
===>  Patching for p5-Module-Signature-0.79
===>   p5-Module-Signature-0.79 depends on package: p5-PAR-Dist>=0 - found
===>   p5-Module-Signature-0.79 depends on executable: gpgv2 - found
===>   p5-Module-Signature-0.79 depends on executable: gcc49 - found
===>   p5-Module-Signature-0.79 depends on file: /usr/local/bin/as - found
===>   p5-Module-Signature-0.79 depends on file: /usr/local/bin/perl5.20.2 - found
===>  Configuring for p5-Module-Signature-0.79
Invalid version format (non-numeric data) at /usr/local/lib/perl5/5.20/vars.pm line 3.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.20/vars.pm line 3.
Compilation failed in require at /usr/local/lib/perl5/site_perl/inc/Module/Install.pm line 14.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/inc/Module/Install.pm line 14.
Compilation failed in require at ./Makefile.PL line 2.
BEGIN failed--compilation aborted at ./Makefile.PL line 2.
*** Error code 255

Stop.
make[1]: stopped in /usr/ports/security/p5-Module-Signature
*** Error code 1

Stop.
make: stopped in /usr/ports/security/p5-Module-Signature

Script done on Fri May 22 06:39:38 2015
Script started on Fri May 22 06:40:08 2015
command: make build
===>  License ART10 GPLv1 accepted by the user
===>   p5-IO-AIO-4.32 depends on file: /usr/local/sbin/pkg - found
=> IO-AIO-4.32.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://cpan.metacpan.org/modules/by-module/IO/IO-AIO-4.32.tar.gz
--2015-05-22 06:40:08--  http://cpan.metacpan.org/modules/by-module/IO/IO-AIO-4.32.tar.gz
Resolving cpan.metacpan.org (cpan.metacpan.org)... 23.235.47.192, 199.27.79.192
Connecting to cpan.metacpan.org (cpan.metacpan.org)|23.235.47.192|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 150475 (147K) [application/x-gzip]
Saving to: 'IO-AIO-4.32.tar.gz'


IO-AIO-4.32.tar.gz             0%[                                               ]       0  --.-KB/s             
IO-AIO-4.32.tar.gz            20%[========>                                      ]  29.70K   148KB/s             
IO-AIO-4.32.tar.gz            39%[=================>                             ]  57.98K   145KB/s             
IO-AIO-4.32.tar.gz            59%[===========================>                   ]  87.67K   144KB/s             
IO-AIO-4.32.tar.gz            79%[====================================>          ] 117.37K   145KB/s             
IO-AIO-4.32.tar.gz           100%[==============================================>] 146.95K   146KB/s   in 1.0s   

2015-05-22 06:40:09 (146 KB/s) - 'IO-AIO-4.32.tar.gz' saved [150475/150475]

===> Fetching all distfiles required by p5-IO-AIO-4.32 for building
===>  Extracting for p5-IO-AIO-4.32
=> SHA256 Checksum OK for IO-AIO-4.32.tar.gz.
===>  Patching for p5-IO-AIO-4.32
===>   p5-IO-AIO-4.32 depends on package: p5-common-sense>=0 - found
===>   p5-IO-AIO-4.32 depends on executable: gcc49 - found
===>   p5-IO-AIO-4.32 depends on file: /usr/local/bin/as - found
===>   p5-IO-AIO-4.32 depends on file: /usr/local/bin/perl5.20.2 - found
===>  Configuring for p5-IO-AIO-4.32
Invalid version format (non-numeric data) at ./Makefile.PL line 1.
BEGIN failed--compilation aborted at ./Makefile.PL line 1.
*** Error code 255

Stop.
make: stopped in /usr/ports/devel/p5-IO-AIO

Script done on Fri May 22 06:40:09 2015
Script started on Fri May 22 06:40:30 2015
command: make build
===>   p5-Devel-Caller-2.06_1 depends on file: /usr/local/sbin/pkg - found
=> Devel-Caller-2.06.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/Devel-Caller-2.06.tar.gz
--2015-05-22 06:40:30--  http://distcache.freebsd.org/ports-distfiles/Devel-Caller-2.06.tar.gz



The same error (3x here) occurs running CLI or GUI 
perl apps... this has persisted for weeks and weeks.  I've
posted to the perl list and the ports list and no fix...



Resolving distcache.freebsd.org (distcache.freebsd.org)... 149.20.53.28, 2001:4f8:3:ffe0:406a:0:16:1c
Connecting to distcache.freebsd.org (distcache.freebsd.org)|149.20.53.28|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6540 (6.4K) [application/octet-stream]
Saving to: 'Devel-Caller-2.06.tar.gz'


Devel-Caller-2.06.tar.gz       0%[                                               ]       0  --.-KB/s             
Devel-Caller-2.06.tar.gz     100%[==============================================>]   6.39K  --.-KB/s   in 0.04s  

2015-05-22 06:40:31 (165 KB/s) - 'Devel-Caller-2.06.tar.gz' saved [6540/6540]

===> Fetching all distfiles required by p5-Devel-Caller-2.06_1 for building
===>  Extracting for p5-Devel-Caller-2.06_1
=> SHA256 Checksum OK for Devel-Caller-2.06.tar.gz.
===>  Patching for p5-Devel-Caller-2.06_1
===>   p5-Devel-Caller-2.06_1 depends on package: p5-PadWalker>=0.08 - found
===>   p5-Devel-Caller-2.06_1 depends on executable: gcc49 - found
===>   p5-Devel-Caller-2.06_1 depends on file: /usr/local/bin/as - found
===>   p5-Devel-Caller-2.06_1 depends on file: /usr/local/bin/perl5.20.2 - found
===>  Configuring for p5-Devel-Caller-2.06_1
Invalid version format (non-numeric data) at /usr/local/lib/perl5/site_perl/ExtUtils/MakeMaker.pm line 6.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/ExtUtils/MakeMaker.pm line 6.
Compilation failed in require at ./Makefile.PL line 4.
BEGIN failed--compilation aborted at ./Makefile.PL line 4.
*** Error code 255

Stop.
make: stopped in /usr/ports/devel/p5-Devel-Caller

Script done on Fri May 22 06:40:31 2015




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1432303889.63155.YahooMailBasic>