Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 23 Nov 2013 12:43:11 -0500
From:      "Mike." <the.lists@mgm51.com>
To:        freebsd-questions@freebsd.org
Subject:   Stumped by gpart and gmirror, trying to set up RAID1 (10.0-Beta3)
Message-ID:  <201311231243110982.00D3BD1B@smtp.24cl.home>

Next in thread | Raw E-Mail | Index | Archive | Help

I'm using 10.0 beta 3.

I'm trying to learn and understand how to set up a RAID1 array.
 I'm using two thumbdrives as the "disks" on my notebook.  The
dmesg for the notebook is at the end of this message.

I've been following the example in The Handbook, section 19.4.2.
Creating a Mirror with Two New Disks

Here's a log of the comamnds and their results:

=== begin log ===============

[root@a20m /etc]# gmirror load

[root@a20m /etc]# gmirror label -v gm0 /dev/da0 /dev/da1
Metadata value stored on /dev/da0.
Metadata value stored on /dev/da1.
Done.

[root@a20m /etc]# gpart create -s MBR mirror/gm0
gpart: geom 'mirror/gm0': File exists

[root@a20m /etc]# gpart show mirror/gm0
=>      1  1981438  mirror/gm0  MBR  (967M)
        1       31              - free -  (16K)
       32  1981407           1  fat32  (967M)


[root@a20m /etc]# gpart delete -i 1 mirror/gm0
mirror/gm0s1 deleted

[root@a20m /etc]# gpart create -s MBR mirror/gm0
gpart: geom 'mirror/gm0': File exists

[root@a20m /etc]#  gpart add -t freebsd -a 4k mirror/gm0
mirror/gm0s1 added

[root@a20m /etc]# gpart show mirror/gm0
=>      1  1981438  mirror/gm0  MBR  (967M)
        1       31              - free -  (16K)
       32  1981376           1  freebsd  (967M)
  1981408       31              - free -  (16K)


[root@a20m /etc]# gpart create -s BSD mirror/gm0s1
mirror/gm0s1 created

[root@a20m /etc]# gpart add -t freebsd-ufs  -a 4k -s 2g
mirror/gm0s1
gpart: autofill: No space left on device

[root@a20m /etc]# 


=== end log ==============





I cannot seem to get past the "gpart: autofill: No space left on
device" error message.


I know I must be missing something obvious, but I am blinded by
my closeness to the problem.

What am I doing wrong?

Thanks.







=== dmesg follows
======================================================

Copyright (c) 1992-2013 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992,
1993, 1994
        The Regents of the University of California. All rights
reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.0-BETA3 #0 r257580: Sun Nov  3 21:15:32 UTC 2013
    root@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC i386
FreeBSD clang version 3.3 (tags/RELEASE_33/final 183502)
20130610
CPU: Intel Pentium III (547.63-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x683  Family = 0x6  Model = 0x8
 Stepping = 3
  Features=0x383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,
PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
real memory  = 268435456 (256 MB)
avail memory = 239337472 (228 MB)
kbd1 at kbdmux0
random: <Software, Yarrow> initialized
acpi0: <PTLTD   RSDT> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, ff00000 (3) failed
cpu0: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x73 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on
acpi0
acpi_ec0: <Embedded Controller: GPE 0x9, GLK> port 0x62,0x66 on
acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82443BX (440 BX) host to PCI bridge> on hostb0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x2000-0x20ff mem
0xf5000000-0xf5ffffff,0xf4200000-0xf4200fff irq 11 at device 0.0
on pci1
cbb0: <TI1450 PCI-CardBus Bridge> mem 0x50000000-0x50000fff irq
11 at device 2.0 on pci0
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb1: <TI1450 PCI-CardBus Bridge> mem 0x50100000-0x50100fff irq
11 at device 2.1 on pci0
cardbus1: <CardBus bus> on cbb1
pccard1: <16-bit PCCard bus> on cbb1
fxp0: <Intel 82559ER Pro/100 Ethernet> port 0x1800-0x183f mem
0xf4120000-0xf4120fff,0xf4100000-0xf411ffff irq 11 at device 3.0
on pci0
miibus0: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> PHY 1 on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto,
auto-flow
fxp0: Ethernet address: 00:10:a4:89:61:bf
pci0: <simple comms, UART> at device 3.1 (no driver attached)
csa0: <CS4280/CS4614/CS4622/CS4624/CS4630> mem
0xf4122000-0xf4122fff,0xf4000000-0xf40fffff irq 11 at device 5.0
on pci0
csa: card is Thinkpad 600X/A20/T20
csa0: [GIANT-LOCKED]
pcm0: <CS461x PCM Audio> on csa0
pcm0: <Cirrus Logic CS4297A AC97 Codec>
pcm0: [GIANT-LOCKED]
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 UDMA33 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1850-0x185f at device 7.1
on pci0
ata0: <ATA channel> at channel 0 on atapci0
ata1: <ATA channel> at channel 1 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port
0x1860-0x187f irq 11 at device 7.2 on pci0
usbus0 on uhci0
pci0: <bridge> at device 7.3 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on
acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq
2 on acpi0
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10
on acpi0
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcffff,0xe0000-0xeffff
pnpid ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem
0xa0000-0xbffff on isa0
ppc0: parallel port not found.
acpi_throttle0: <ACPI CPU Throttling> on cpu0
smist0: <SpeedStep SMI> on cpu0
Timecounters tick every 1.000 msec
random: unblocking device.
usbus0: 12Mbps Full Speed USB v1.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>
on usbus0
ada0 at ata0 bus 0 scbus0 target 0 lun 0
ada0: <IC25N020ATCS05-0 CS2OA63A> ATA-5 device
ada0: Serial Number CLP229F2G7N6GA
ada0: 33.300MB/s transfers (UDMA2, PIO 8192bytes)
ada0: 19077MB (39070080 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad0
cd0 at ata1 bus 0 scbus1 target 0 lun 0
cd0: <LG CD-ROM CRN-8241U 2.24> Removable CD-ROM SCSI-0 device 
cd0: Serial Number 2000/01/19
cd0: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not
present
battery0: critically low charge!
Timecounter "TSC" frequency 547632049 Hz quality 800
uhub0: 2 ports with 2 removable, self powered
Root mount waiting for: cbb1
Trying to mount root from ufs:/dev/ada0p2 [rw]...
ugen0.2: <vendor 0x1a40> at usbus0
uhub1: <vendor 0x1a40 USB 2.0 Hub, class 9/0, rev 2.00/1.11,
addr 2> on usbus0
uhub1: 4 ports with 4 removable, self powered
ugen0.3: <USB 2.0> at usbus0
umass0: <USB 2.0 Flash Disk, class 0/0, rev 2.00/11.00, addr 3>
on usbus0
umass0:  SCSI over Bulk-Only; quirks = 0x4000
umass0:2:0:-1: Attached to scbus2
da0 at umass-sim0 bus 0 scbus2 target 0 lun 0
da0: <USB 2.0 Flash Disk 1100> Removable Direct Access SCSI-0
device 
da0: Serial Number AA40000000003903
da0: 1.000MB/s transfers
da0: 967MB (1981440 512 byte sectors: 64H 32S/T 967C)
da0: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>
ugen0.4: <USB 2.0> at usbus0
umass1: <USB 2.0 Flash Disk, class 0/0, rev 2.00/11.00, addr 4>
on usbus0
umass1:  SCSI over Bulk-Only; quirks = 0x4000
umass1:3:1:-1: Attached to scbus3
da1 at umass-sim1 bus 1 scbus3 target 0 lun 0
da1: <USB 2.0 Flash Disk 1100> Removable Direct Access SCSI-0
device 
da1: Serial Number AA40000000003840
da1: 1.000MB/s transfers
da1: 967MB (1981440 512 byte sectors: 64H 32S/T 967C)
da1: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?201311231243110982.00D3BD1B>