Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 27 Dec 2006 22:49:32 +0300
From:      Boris Samorodov <bsam@ipt.ru>
To:        "Jim Stapleton" <stapleton.41@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: linux compatability question
Message-ID:  <00451827@bsam.ru>
In-Reply-To: <80f4f2b20612271102p6b2332b9raf716dfd36b8e310@mail.gmail.com> (Jim Stapleton's message of "Wed, 27 Dec 2006 14:02:39 -0500")
References:  <80f4f2b20612271102p6b2332b9raf716dfd36b8e310@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Wed, 27 Dec 2006 14:02:39 -0500 Jim Stapleton wrote:

> I'm not sure what to do at this point, I'm trying to run a linux app
> (binary) that requires libGLU.so.1, and it's an x86 binary.

It requires a linux library.

> When I first ran it, it complained that the file libGLU.so.1 could not
> be found (it was in my /usr/X11R6/lib directory. I made a simlink with

And that is a FreeBSD one.

> that name to that file to /compat/linux/usr/X11R6/lib and now get this
> error:

> ./partiview: error while loading shared libraries: /lib/libGLU.so.1:
> ELF file OS ABI invalid

Yes, the linux app tries to load a FreeBSD library.

> This is on an i950 based notebook (integrated intel graphics), using
> the i810 and vga drivers in X. FreeBSD 6.1,  X is either 6.8 or 6.9

> Any suggestions?

Remove your simlink and install graphics/linux-libGLU.


WBR
-- 
Boris Samorodov (bsam)
Research Engineer, http://www.ipt.ru Telephone & Internet SP
FreeBSD committer, http://www.FreeBSD.org The Power To Serve



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?00451827>