Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 31 Jul 2017 17:40:36 +0200
From:      Polytropon <freebsd@edvax.de>
To:        Duane Whitty <duane@nofroth.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Wireless on Dell Latitude D630
Message-ID:  <20170731174036.c6675425.freebsd@edvax.de>
In-Reply-To: <a20418fe-6e76-a7b6-a25f-97b73191d115@nofroth.com>
References:  <a20418fe-6e76-a7b6-a25f-97b73191d115@nofroth.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 31 Jul 2017 12:19:27 -0300, Duane Whitty wrote:
> Polytropon, in an earlier thread on this list (FreeBSD 11.1, Xfce, and
> laptop screen and external monitor resolution) you mentioned you were
> using a Dell Latitude D630.  Do you have the wireless working under
> FreeBSD on that machine?  I am writing this email from D630.

Yes, it works very nicely, even though I do not regularly use it
due to a "fixed installation" of that particular machine, even
with a docking station. :-)

In /boot/loader.conf, I have

	wpi_load="YES"

And in /etc/rc.conf:

	wlans_wpi0="wlan0"
	ifconfig_wlan0="WPA DHCP"

accompanied by the required settings in /etc/wpa_supplicant.conf
to connect to the WLAN (if enabled).

Also the fully manual approach to connect (as explained in the
handbook) can be used, also works fully as expected with that
particular machine.

I also got wpa_gui working on X (but for a "fixed installation"
it's mostly nonsense).

Very helpful in setting up the WLAN component:

http://www.wonkity.com/~wblock/docs/html/wireless.html

Yes, it actually _is_ that easy. :-)



-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20170731174036.c6675425.freebsd>