Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 8 Jun 2013 12:33:47 -0600 (MDT)
From:      Warren Block <wblock@wonkity.com>
To:        Sasha and Tanya Kapshuk <sashaandtanya@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: trouble setting up wireless
Message-ID:  <alpine.BSF.2.00.1306081231490.63741@wonkity.com>
In-Reply-To: <51B37351.4060709@gmail.com>
References:  <51B35217.9080003@gmail.com> <alpine.BSF.2.00.1306081202210.63741@wonkity.com> <51B37351.4060709@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 8 Jun 2013, Sasha and Tanya Kapshuk wrote:

> On 06/08/2013 09:03 PM, Warren Block wrote:
>> 
>>> Howdy,
>>> 
>>> Been trying to setup wireless on a laptop with an Atheros 5424/2424 card 
>>> running FreeBSD 9.1-RELEASE.
>>> 
>>> Been following the instructions given in the handbook.
>>> 
>>> Running 'ifconfig wlan0 up scan' does not seem to return anything. What am 
>>> I doing wrong?
>> 
>> That should be 'ifconfig wlan0 up list scan'. 
> Tried that. Still no output.
>
> I see that my card being identified as AR2425 is supported by the ath_hal(4) 
> module. How do I enable it?

Both are built into the GENERIC kernel.  If you've built a custom 
kernel, you'll have to load them in /boot/loader.conf.

> Here's whta I've got in my /etc/rc.conf:
>
> if_ath_load="YES"
> if_ath_pci_load="YES"

Right, but those go in /boot/loader.conf.  Not needed if you're using 
the GENERIC kernel, though.

> ifconfig says 'no carrier' for wlan0.

Here's my "short form" wireless article:

http://www.wonkity.com/~wblock/docs/html/wireless.html



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1306081231490.63741>