Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 23 Nov 2011 20:31:31 -0800
From:      Robert <traveling08@cox.net>
To:        freebsd-questions@freebsd.org <freebsd-questions@freebsd.org>
Subject:   Fw: Invalid fdisk partition table found
Message-ID:  <20111123203131.3e8d5a63@dell64>

Next in thread | Raw E-Mail | Index | Archive | Help
Just noticed that I did not include questions@. It has been a long day.

Begin forwarded message:

Date: Wed, 23 Nov 2011 19:21:54 -0800
From: Robert <traveling08@cox.net>
To: "Julian H. Stacey" <jhs@berklix.com>
Subject: Re: Invalid fdisk partition table found


Julian and Warren thanks for the responses. 

On Wed, 23 Nov 2011 22:08:00 +0100
"Julian H. Stacey" <jhs@berklix.com> wrote:

> Robert wrote:
> > Greetings
> > 
> > [robert@dell64] ~> uname -a
> > FreeBSD dell64.shasta204.local 8.2-STABLE FreeBSD 8.2-STABLE #34:
> > Fri Nov 18 06:43:01 PST 2011
> > root@dell64.shasta204.local:/usr/obj/usr/src/sys/GENERIC  amd64 
> > 
> > I have two Lexar Professional 600X 16GB compact flash cards that are
> > unusable. fdisk shows:
>
<clip>

> > Is there any way I can restore these CF cards to 16GB? Any help or
> > suggestions will be greatly appreciated.
> 
> @ suggestions:
> 1 Try
> 	bsdlabel -B -w -r /dev/da1

[robert@dell64] ~> sudo bsdlabel -B -w -r /dev/da1
Password:
[robert@dell64] ~> 


> 	echo unplug, reinsert

Not sure if you actually wanted me to unplug and reinsert the CF
card...so I did both
[robert@dell64] ~> echo unplug, reinsert
unplug, reinsert

and physically unplugged and reinserted the CF card

> 	newfs /dev/da1a
                      ^ ???

[robert@dell64] ~> sudo newfs /dev/da1a
newfs: /dev/da1a: could not find special device
[robert@dell64] ~> sudo newfs /dev/da1
/dev/da1: 29.5MB (60480 sectors) block size 16384, fragment size 2048
	using 4 cylinder groups of 7.39MB, 473 blks, 960 inodes.
super-block backups (for fsck -b #) at:
 160, 15296, 30432, 45568
cg 0: bad magic number
[robert@dell64] ~> 

fdisk /dev/da1
******* Working on device /dev/da1 *******
parameters extracted from in-core disklabel are:
cylinders=29 heads=64 sectors/track=32 (2048 blks/cyl)

parameters to be used for BIOS calculations are:
cylinders=29 heads=64 sectors/track=32 (2048 blks/cyl)

fdisk: invalid fdisk partition table found
Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
    start 32, size 59360 (28 Meg), flag 80 (active)
	beg: cyl 0/ head 1/ sector 1;
	end: cyl 28/ head 63/ sector 32
The data for partition 2 is:
<UNUSED>
The data for partition 3 is:
<UNUSED>
The data for partition 4 is:
<UNUSED>

No change from before.

> 
> 2 Base of _my_ man fdisk
> "     When running multi user, you cannot write unless you first run
> this: sysctl kern.geom.debugflags=16

I had failed to mention in the original post that I had seen something
in my searches about problems since 7.1. I had tried booting from an
old 6.2 disk and attempted all of this under "fixit" with no luck.

And also tried in single user mode.


Warren,
[robert@dell64] ~> sudo gpart destroy -F da1
gpart: geom 'da1': Invalid argument


[robert@dell64] ~> sudo gpart create -s GPT da1
da1 created

[robert@dell64] ~> sudo gpart bootcode -b /boot/pmbr da1
bootcode written to da1

[robert@dell64] ~> sudo gpart destroy -F da1
da1 destroyed

[robert@dell64] ~> fdisk /dev/da1
******* Working on device /dev/da1 *******
parameters extracted from in-core disklabel are:
cylinders=29 heads=64 sectors/track=32 (2048 blks/cyl)

parameters to be used for BIOS calculations are:
cylinders=29 heads=64 sectors/track=32 (2048 blks/cyl)

fdisk: invalid fdisk partition table found
Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
    start 32, size 59360 (28 Meg), flag 80 (active)
	beg: cyl 0/ head 1/ sector 1;
	end: cyl 28/ head 63/ sector 32
The data for partition 2 is:
<UNUSED>
The data for partition 3 is:
<UNUSED>
The data for partition 4 is:
<UNUSED>

I see the flashing lights like it is writing to the CF card but nothing
changes. 

More suggestions welcome. These are quite expensive CF cards.

Thanks again
Robert




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20111123203131.3e8d5a63>