Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 12 Apr 2012 16:13:11 +0200
From:      Damien Fleuriot <ml@my.gd>
To:        KES <kes-kes@yandex.ua>
Cc:        "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   Re: Problem with vlans on igb (was: fsck problem FreeBSD 8.3)
Message-ID:  <CAE63ME63PiY=BfHCJfxi2kU_FkrUGrkhU3X6dD-G1fW-hVA_HA@mail.gmail.com>
In-Reply-To: <505981334167684@web133.yandex.ru>
References:  <505981334167684@web133.yandex.ru>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Try disabling hardware VLAN tagging like so, I know we had problems a
few years back with it.

in /etc/rc.conf :
ifconfig_igb2=3D" -vlanhwtag -tso -lro up"


2012/4/11 KES <kes-kes@yandex.ua>:
>
>
> -------- =F0=C5=D2=C5=D3=D9=CC=C1=C5=CD=CF=C5 =D3=CF=CF=C2=DD=C5=CE=C9=C5=
 =9A--------
> 11.04.2012, 13:14, "KES" <kes-kes@yandex.ua>:
>
> 10.04.2012, 08:50, "Da Rock" <freebsd-questions@herveybayaustralia.com.au=
>:
>
>> =9AOn 04/10/12 05:02, =EB=CF=CE=D8=CB=CF=D7 =E5=D7=C7=C5=CE=C9=CA wrote:
>>> =9A=9AYes, I have tested.
>>> =9A=9Aand on this hardware on this OS it works from =9AFri Feb 24 17:07=
:48 UTC 2012
>>> =9A=9Abut last two days:
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9AMon Apr =9A9 19:50
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9AMon Apr =9A9 18:30
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASun Apr =9A8 20:55
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASun Apr =9A8 20:00
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASun Apr =9A8 19:49
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASun Apr =9A8 17:43
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASun Apr =9A8 10:58
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASat Apr =9A7 21:13
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASat Apr =9A7 16:37
>>> =9A=9Areboot =9A=9A=9A=9A=9A=9A=9A=9A=9A=9A~ =9A=9A=9A=9A=9A=9A=9A=9A=
=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9A=9ASat Apr =9A7 16:07
>>>
>>> =9A=9AI remembered. One thing changed.
>>> =9A=9AI add vlans to igb2, but no traffic flow on that devices yet.
>> =9APerhaps you should test removing the vlans and see if things improve?
>
> I have removed vlans, two day server works without reboots
>
>>> =9A=9ABefore this I have use: igb0, igb1, igb3
>>> =9A=9Aigb0@pci0:1:0:0: =9A=9A=9A=9A=9A=9A=9Aclass=3D0x020000 card=3D0x0=
0018086 chip=3D0x15218086 rev=3D0x01 hdr=3D0x00
>>> =9A=9A=9A=9A=9A=9A=9Avendor =9A=9A=9A=9A=3D 'Intel Corporation'
>>> =9A=9A=9A=9A=9A=9A=9Aclass =9A=9A=9A=9A=9A=3D network
>>> =9A=9A=9A=9A=9A=9A=9Asubclass =9A=9A=3D ethernet
>>> =9A=9Aigb1@pci0:1:0:1: =9A=9A=9A=9A=9A=9A=9Aclass=3D0x020000 card=3D0x0=
0018086 chip=3D0x15218086 rev=3D0x01 hdr=3D0x00
>>> =9A=9A=9A=9A=9A=9A=9Avendor =9A=9A=9A=9A=3D 'Intel Corporation'
>>> =9A=9A=9A=9A=9A=9A=9Aclass =9A=9A=9A=9A=9A=3D network
>>> =9A=9A=9A=9A=9A=9A=9Asubclass =9A=9A=3D ethernet
>>> =9A=9Aigb2@pci0:1:0:2: =9A=9A=9A=9A=9A=9A=9Aclass=3D0x020000 card=3D0x0=
0018086 chip=3D0x15218086 rev=3D0x01 hdr=3D0x00
>>> =9A=9A=9A=9A=9A=9A=9Avendor =9A=9A=9A=9A=3D 'Intel Corporation'
>>> =9A=9A=9A=9A=9A=9A=9Aclass =9A=9A=9A=9A=9A=3D network
>>> =9A=9A=9A=9A=9A=9A=9Asubclass =9A=9A=3D ethernet
>>> =9A=9Aigb3@pci0:1:0:3: =9A=9A=9A=9A=9A=9A=9Aclass=3D0x020000 card=3D0x0=
0018086 chip=3D0x15218086 rev=3D0x01 hdr=3D0x00
>>> =9A=9A=9A=9A=9A=9A=9Avendor =9A=9A=9A=9A=3D 'Intel Corporation'
>>> =9A=9A=9A=9A=9A=9A=9Aclass =9A=9A=9A=9A=9A=3D network
>>> =9A=9A=9A=9A=9A=9A=9Asubclass =9A=9A=3D ethernet
>>>
>>> =9A=9Aifconfig_vlan100=3D"inet =9A192.168.0.1 netmask 255.255.255.0 vla=
n 100 vlandev igb2" #nALL
>>> =9A=9Aifconfig_vlan101=3D"inet =9A192.168.1.1 netmask 255.255.255.0 vla=
n 101 vlandev igb2" #n2 p24
>>> =9A=9Aifconfig_vlan102=3D"inet =9A192.168.2.1 netmask 255.255.255.0 vla=
n 102 vlandev igb2" #n1 p23
>>> =9A=9Aifconfig_vlan103=3D"inet =9A192.168.3.1 netmask 255.255.255.0 vla=
n 103 vlandev igb2" #n3 p22
>>> =9A=9Aifconfig_vlan104=3D"inet =9A192.168.4.1 netmask 255.255.255.0 vla=
n 104 vlandev igb2" #n7,9 p21
>>> =9A=9Aifconfig_vlan105=3D"inet =9A192.168.5.1 netmask 255.255.255.0 vla=
n 105 vlandev igb2" #n11 p20
>>> =9A=9Aifconfig_vlan106=3D"inet =9A192.168.6.1 netmask 255.255.255.0 vla=
n 106 vlandev igb2" #n13 p19
>>> =9A=9Aifconfig_vlan107=3D"inet =9A192.168.7.1 netmask 255.255.255.0 vla=
n 107 vlandev igb2" #n223 p18
>>> =9A=9Aifconfig_vlan108=3D"inet =9A192.168.8.1 netmask 255.255.255.0 vla=
n 108 vlandev igb2" #n225 p17
>>> =9A=9Aifconfig_vlan109=3D"inet =9A192.168.9.1 netmask 255.255.255.0 vla=
n 109 vlandev igb2" #n221 p16
>>> =9A=9Aifconfig_vlan110=3D"inet 192.168.10.1 netmask 255.255.255.0 vlan =
110 vlandev igb2" #n229 p15
>>> =9A=9Aifconfig_vlan111=3D"inet 192.168.11.1 netmask 255.255.255.0 vlan =
111 vlandev igb2" #n233 p14
>>> =9A=9Aifconfig_vlan112=3D"inet 192.168.12.1 netmask 255.255.255.0 vlan =
112 vlandev igb2" #n231 p13
>>> =9A=9Aifconfig_vlan113=3D"inet 192.168.13.1 netmask 255.255.255.0 vlan =
113 vlandev igb2" #n237 p12
>>> =9A=9Aifconfig_vlan114=3D"inet 192.168.14.1 netmask 255.255.255.0 vlan =
114 vlandev igb2" #n424 p11
>>> =9A=9Aifconfig_vlan115=3D"inet 192.168.15.1 netmask 255.255.255.0 vlan =
115 vlandev igb2" #
>>>
>>> =9A=9APAP> =9ANothing logged in /var/log/* or crashes that exist in /va=
r/crash
>>> =9A=9APAP> =9Awould indicate to me some sort of hardware related proble=
m.
>>> =9A=9APAP> =9AHave you tested your hardware lately and know that it is =
in operational order?
>>>
>>> =9A=9APAP> =9A~Paul
>>>
>>> =9A=9APAP> =9AOn Mon, Apr 09, 2012 at 09:36:54PM +0300, ??????? ???????=
 wrote:
>>>>> =9A=9AHi.
>>>>>
>>>>> =9A=9AApr =9A9 19:51:58 fsck: /dev/ad8s1e: UNEXPECTED INCONSISTENCY, =
CANNOT RUN FAST FSCK
>>>>> =9A=9AApr =9A9 19:51:58 fsck:
>>>>> =9A=9AApr =9A9 19:51:58 fsck:
>>>>> =9A=9AApr =9A9 19:51:58 fsck: /dev/ad8s1e: UNEXPECTED INCONSISTENCY; =
RUN fsck MANUALLY.
>>>>> =9A=9AApr =9A9 19:51:58 fsck: /dev/ad8s1e: CANNOT SET FS_NEEDSFSCK FL=
AG
>>>>> =9A=9AApr =9A9 20:09:22 kernel:
>>>>>
>>>>> =9A=9Arunning manually:
>>>>> =9A=9A# fsck -y /dev/ad8s1e
>>>>> =9A=9A** /dev/ad8s1e (NO WRITE)
>>>>> =9A=9A** Last Mounted on /tmp
>>>>> =9A=9A** Phase 1 - Check Blocks and Sizes
>>>>> =9A=9A** Phase 2 - Check Pathnames
>>>>> =9A=9A** Phase 3 - Check Connectivity
>>>>> =9A=9A** Phase 4 - Check Reference Counts
>>>>> =9A=9A** Phase 5 - Check Cyl groups
>>>>> =9A=9A99 files, 10 used, 506477 free (45 frags, 63304 blocks, 0.0% fr=
agmentation)
>>>>>
>>>>> =9A=9AServer reboot two or three time per day
>>>>> =9A=9A# uname -a
>>>>> =9A=9AFreeBSD flux 8.3-PRERELEASE FreeBSD 8.3-PRERELEASE #3 r231881: =
Fri Feb 24 17:07:48 UTC 2012 =9A=9A=9A=9Aadm@flux:/usr/obj/usr/src/sys/KES_=
KERN_v8 =9Aamd64
>>>>>
>>>>> =9A=9Abefore this it works about month without problems
>>>>>
>>>>> =9A=9A/var/crash - empty, in /var/log/messages there is no any messag=
es before crash.
>>>>> =9A=9ACan any help to fix problem?
>> =9A_______________________________________________
>> =9Afreebsd-questions@freebsd.org mailing list
>> =9Ahttp://lists.freebsd.org/mailman/listinfo/freebsd-questions
>> =9ATo unsubscribe, send any mail to "freebsd-questions-unsubscribe@freeb=
sd.org"
> -------- =FA=C1=D7=C5=D2=DB=C5=CE=C9=C5 =D0=C5=D2=C5=D3=D9=CC=C1=C5=CD=CF=
=C7=CF =D3=CF=CF=C2=DD=C5=CE=C9=D1 --------
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.o=
rg"



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAE63ME63PiY=BfHCJfxi2kU_FkrUGrkhU3X6dD-G1fW-hVA_HA>