Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 7 Jun 2005 18:08:35 +0200
From:      "Daniel Eriksson" <daniel_k_eriksson@telia.com>
To:        <freebsd-current@FreeBSD.org>
Subject:   RE: Livelock seen on current with threaded processes 
Message-ID:  <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAATEoshQLipUS7nVbmK/MJigEAAAAA@telia.com>
In-Reply-To: <20050607153322.208B85D07@ptavv.es.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Kevin Oberman wrote:

> Yes, it does sound similar. I was hoping that your thread 
> would lead to
> a resolution of my problem. I can certainly believe that the 
> problem is
> VM related. Unfortunately, I believe the work-around was to set
> debug.mpsafevm to 1, but that didn't seem to help at my case at all.
> 
> Am I remembering correctly?

Not quite. Turning mpsafevm off prevented my machines from completely
locking up, but they still entered a mostly useless state where simple
commands such as 'ps' or 'ls' could take a minute or more to execute.

However, since the complete lock-ups only happened when I provoked the
machine (never during regular operation) I continued to run with mpsafevm
enabled.

I'm not in a position to test the 'dd' trick right now, but I'll try to do
that later tonight to see if it still locks the machine up.

/Daniel Eriksson





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAATEoshQLipUS7nVbmK/MJigEAAAAA>