Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 13 Dec 2017 20:35:12 +0100
From:      Polytropon <freebsd@edvax.de>
To:        Mike Tancsa <mike@sentex.net>
Cc:        fml <tetrosalame@gmail.com>, freebsd-questions@freebsd.org
Subject:   Re: FreeBSD 11.1 on Soekris NET4501. Storage issue
Message-ID:  <20171213203512.268d8006.freebsd@edvax.de>
In-Reply-To: <e3c5d44d-fdf7-7279-af41-8ac0b698c730@sentex.net>
References:  <20171212185233.GA1732@avalon.thwn> <abec4ab7-6d1d-08ef-8286-819aadd3a2ff@sentex.net> <20171213192321.GA1651@avalon.thwn> <e3c5d44d-fdf7-7279-af41-8ac0b698c730@sentex.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Wed, 13 Dec 2017 13:44:58 -0500, Mike Tancsa wrote:
> On 12/13/2017 2:23 PM, fml wrote:
> > On Wed, Dec 13, 2017 at 10:54:01AM -0500, Mike Tancsa wrote:
> >>> (aprobe0:ata0:0:0:0): RES: 51 04 00 00 00 00 00 00 00 0c 00
> >>> (aprobe0:ata0:0:0:0): Error 5, Retries exhausted
> >>> Trying to mount root from ufs:/dev/ada0s1a [ro]...
> >>> mountroot: waiting for device /dev/ada0s1a...
> >>
> >> Its been a LONG time since I booted one of these, but I seem to recall
> >> it was quite particular about setting how the disk was accessed.  I
> >> recall having to set something in /boot/loader.conf. Maybe the sata
> >> version ? dma mode ?
> 
> 
> hw.ata.ata_dma=0
> hw.ata.atapi_dma=0
> 
> were the two I was thinking about

On my ye olde home PC, I have those in /boot/loader.conf:

	hw.ata.atapi_dma="1"
	hw.ata.ata_dma="1"
	hw.ata.wc="0"

The descriptions are:

hw.ata.atapi_dma: ATAPI device DMA mode control
hw.ata.ata_dma: ATA disk DMA mode control
hw.ata.wc: ATA disk write caching

Maybe this will help?


-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20171213203512.268d8006.freebsd>