Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 29 Aug 2006 00:03:49 -0700
From:      "Muhammad Omer Iqbal" <omer@omeriqbal.com>
To:        <freebsd-questions@freebsd.org>
Subject:   RE: PHP5 and MySQL
Message-ID:  <000001c6cb39$4a2d1240$dadd51cb@rakaposhi>
In-Reply-To: <20060827190247.BA25.GERARD@seibercom.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
So it seems that my ports collectionwas indeed out of date, even though I
installed FreeBSD 6.1 only two weeks back. Lesson learnt: always update
ports collection after installing FreeBSD.

I am doing MySQL 5.0 instead of 5.1, I do not want a beta release, and I am
comparing and doing an analysis against a propreitary DB. I have used MySQL
in the past, and believe it is a better choice for our case.

Thanks for all the help, esp Gerard, Matthew & fbsd. I am going to try and
build/install everything. If I run into problems again and I run out of
everything, I will come back here.

Thanks folks!
Best Wishes,
Omer

-----Original Message-----
From: Gerard Seibert [mailto:gerard@seibercom.net] 
Sent: Sunday, August 27, 2006 4:18 PM
To: Muhammad Omer Iqbal
Subject: Re: PHP5 and MySQL

It certainly sounds like you have an old version of the ports tree
installed.

They this and see if it corrects things. Have you ever run 'portsnap'?
If not, now is a good time to start.

As root, run the following:

portsnap fetch
portsnap extract
portsnap update

The extract command will take awhile, but it only has to be run once.
After this, anytime you want to update the ports tree you would simply
run:

portsnap fetch update

The three commands I gave you will rebuild build your ports tree with the
latest updates.

Now, ,migrate to /usr/ports/databases/mysql51-server and run:

make install && make clean

If it complains about any other version being installed you will have to
navigate to that directory and run make deinstall to remove it manually.
Then return and run the above command again/

Next, navigate to the /usr/ports/lang/php5 directory and run 

make config

Make sure that the "Build Apache Module" is checked Leave the others at
there default settings. Make sure you do 'tab' to OK and hit return to save
the settings.

Now, enter: make install && make clean

When finished, everything should be running correctly. If you have not done
so already, you must place:

mysql_enable="YES"

in the /etc/rc.conf file. Now reboot the system and all should be well.

Ciao!

--
Gerard Seibert
gerard@seibercom.net




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001c6cb39$4a2d1240$dadd51cb>