Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 3 Jul 2007 16:09:37 -0400
From:      John Nielsen <lists@jnielsen.net>
To:        freebsd-questions@freebsd.org
Cc:        gnome@freebsd.org, epf1@cec.wustl.edu, Dan Nelson <dnelson@allantgroup.com>
Subject:   Re: can't build /graphics/poppler-qt after recent cvsup
Message-ID:  <200707031609.37422.lists@jnielsen.net>
In-Reply-To: <20070703195222.GB1289@dan.emsphone.com>
References:  <4986.209.145.181.6.1183488849.squirrel@hive.cec.wustl.edu> <20070703195222.GB1289@dan.emsphone.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
[cc-ing gnome@ as port maintainer]

On Tuesday 03 July 2007 03:52:22 pm Dan Nelson wrote:
> In the last episode (Jul 03), epf1@cec.wustl.edu said:
> > I'm having an odd proble getting poppler-qt to build after my latest
> > cvsup.
> >
> > I use portmanager to update my ports and when I ran it today I got the
> > following failure as the poppler-qt port was doing it's configure:
> >
> > ---Snip------
> > checking for Qt headers... /usr/local/include
> > checking for Qt libraries... /usr/local/lib
> > test: xyes: unexpected operator
> > configure: error: Qt development libraries not found
>
> It looks like QT's autoconf test is buggy.
> work/poppler-0.5.4/configure script, line 25757:
>
> if test "x$have_qt4" == "xyes"; then
>
> "==" is not a valid comparison operator for the test command.  It must
> be "=".

I was having the same problem as the OP. After Dan's post I did a "make 
patch", then modified the configure script replacing two instances of == with 
= on these two lines:

25851:if test "x$have_qt" == "xyes"; then
26033:if test "x$have_qt" == "xyes"; then

After that I was able to make and install the port.

gnome@ folks, should I submit a PR or will you guys just take this upstream 
directly?

JN



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200707031609.37422.lists>