Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 29 Jun 2013 23:23:45 +0530
From:      Manish Jain <bourne.identity@hotmail.com>
To:        freebsd-questions@freebsd.org
Subject:   Problems getting my Huawei 0x140b USB modem to speak to internet
Message-ID:  <BLU0-SMTP435AA0F73514D52825A751AF6770@phx.gbl>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello All,

I have a a Huawei USB modem (product id 0x140b) which is connected to my 
PC. I downloaded and installed Draisberghof's usb_modeswitch.

The following are the contents of my /etc/usb_modeswitch.conf :

DisableSwitching=0
EnableLogging=1
DefaultVendor=0x12d1
DefaultProduct=0x140b
TargetVendor=0x12d1
TargetProduct=0x1446
CheckSuccess=20
MessageEndpoint=0x0f
MessageContent="55534243123456780000000000000011062000000100000000000000000000"

When I run usb_modeswitch -c /etc/usb_modeswitch.conf, I get the 
following message :

Looking for target devices ...
  No devices in target mode or class found
Looking for default devices ...
    found matching product ID
    adding device
  Found device in default mode, class or configuration (1)
Accessing device 010 on bus 000 ...
Getting the current device configuration ...
  OK, got current device configuration (1)
Using interface number 0
Error: can't use storage command in MessageContent with interface 0;
        interface class is 255, should be 8. Aborting.


So my FreeBSD box cannot speak to internet and I have boot MS-DOG for 
this holy purpose. Can someone please suggest a remedy ?

Thanks in advance &
-- 
Regards,

Manish Jain
+91-88064-38388



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?BLU0-SMTP435AA0F73514D52825A751AF6770>