Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 15 Jul 2018 11:45:52 -0400
From:      Ajtim <starikarp@yandex.com>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: webcamd
Message-ID:  <20180715114552.113158bc@yandex.com>
In-Reply-To: <20180714184029.3231e83e@yandex.com>
References:  <20180714184029.3231e83e@yandex.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 14 Jul 2018 18:40:29 -0400
Ajtim <starikarp@yandex.com> wrote:

> Hi!
> 
> My system is FreeBSD 11.2-RELEASE (amd64) and it is installed on iMac
> 11,1 which has a built-in iSight video camera.
> It worked and it works after todays update too. After update I have
> video0 and video1 and both work the same.
> 
> But my problem is sound in mpv player. I start with  
> mpv tv://v42: device=/dev/video0 
> [tv] Selected driver: v4l2
> [tv]  name: Video 4 Linux 2 input
> [tv] your device driver does not support VIDIOC_G_STD ioctl,
> VIDIOC_G_PARM was used instead. [tv] Selected device: Built-in iSight:
> Built-in iSigh [tv]  Capabilities:  video capture  read/write
> streaming [tv]  supported norms:
> [tv]  inputs: 0 = Camera 1;
> [tv]  Current input: 0
> [tv]  Current format: YUYV
> [tv] tv.c: norm_from_string(pal): Bogus norm parameter, setting
> default. [tv] ioctl enum norm failed: Invalid argument
> [tv] Error: Cannot set norm!
> [tv] Selected input hasn't got a tuner!
> [tv] ioctl set mute failed: Invalid argument
>  (+) Video --vid=1 (rawvideo 640x480 30.000fps)
> VO: [gpu] 640x480 yuv420p
> 
> I had the same problem with sound on VLC player.
> 
> But if I use:
>  mencoder tv://
> -tvdriver=v4l2:width=420:height=340:device=/dev/video0:forceaudio:adevice=/dev/dsp1
> -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o
> webcam.avimencoder tv:// -tv
> driver=v4l2:width=420:height=340:device=/dev/video0:forceaudio:adevice=/dev/dsp1
> -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o
> webcam2.avidevice=/dev/video0:forceaudio:adevice=/dev/dsp1 -ovc lavc
> -oac mp3lame -lameopts cbr:br=64:mode=3 -o webcam.avi
> 
> It save webcam.avi with sound. 
> 
> Any idea how to get sound on mpv player, please?
> 
> Thank you.
> 
> SK

I have something more. With ffmpeg I got sound:
 ffmpeg -f v4l2 -video_size 640x480 -i /dev/video0 -f sndio -i default -c:v libx264 -preset ultrafast -c:a aac webcam.mp

But if I use oss than doesn't work. Or I am doing something wrong.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20180715114552.113158bc>