Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 4 Jan 1996 15:10:09 -0700
From:      Nate Williams <nate@rocky.sri.MT.net>
To:        jlrobins@zappa.cs.uncc.edu
Cc:        questions@freebsd.org
Subject:   Re: pppd only works right the first time :-(
Message-ID:  <199601042210.PAA02214@rocky.sri.MT.net>
In-Reply-To: <9601042132.AA05294@zappa.cs.uncc.edu>
References:  <9601042132.AA05294@zappa.cs.uncc.edu>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
jlrobins@zappa.cs.uncc.edu writes:
> Yet another PPP question -- 2.1-stable
> 
> I have a site that I'm trying to set up as a one line PPP server using
> pppd. It answers the telephone correctly for shell use.
> 
> After a reboot, the first call is handled perfectly. It ifconfigs the
> ppp0 interface, it adds the route, and then proxyarp's for the remote
> machine. Cool Moe D.
> 
> When the second call comes in, pppd gets started up and complains with
> "ioctl(SIOCAIFADDR): Address already exists". No route entry is added.
> No proxy arp is done. Person on the other end can't see anywhere.

Hmm, this seems strange to me, since I've got a similar setup (but with
multiple incoming lines and one outgoing line).  I don't have the
addresses hard-coded in my options file though.

How long of a time exists between the time the first machine logs out
and the second machine connects?

It *could* be the arp bug I've posted about in the past, although I
don't seen any errors.  Is there anyway of connecting via a shell
account in between and looking at the routing table?

I've got a couple others ideas that might work, but let's try and track
down the problem first.



Nate



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?199601042210.PAA02214>