Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 14 Dec 2013 21:20:18 -0800
From:      Eric Dynamic <ecsd@transbay.net>
To:        freebsd-questions@FreeBSD.org
Subject:   concerning loader.conf(5)
Message-ID:  <52AD3C12.301@transbay.net>

Next in thread | Raw E-Mail | Index | Archive | Help
   There's the issue where you move disks from installed system A to a
   different motherboard
   and the system can't boot because it remembers the old system's device
   names.
   Where is the fix for this documented?
   I examined /boot/defaults/loader.conf and I believe the lines in
   question - for a /boot/loader.conf
   file I would create as the override for the problem are these:
   #currdev="disk1s1a"     # Set the current device
   #root_disk_unit="0"     # Force the root disk unit number
   #rootdev="disk1s1a"     # Set the root filesystem
   I'll guess that "rootdev" is all I need to specify, or possibly
   "currdev" as well.
   I have this nit to pick: the loader.conf man page does NOT describe
   these labels at all,
   and the Online Manual in describing the boot process makes no mention
   of this mechanism,
   either.
   Moreover, there is no "/boot/loader.conf" file because by default it
   isn't needed until it is needed;
   but in looking at /boot/defaults/loader.conf it contains all
   commented-out lines line the ones above,
   and I can't tell where the system is making the determination as to
   what device it was installed on
   to begin with - namely, where IS the system storing the memory of what
   disk it wishes to try to load
   the system from? If the system calculated that based on the
   (in-disk-label) stated identity of the
   disk the boot process boots from, then the paradox is that even though
   the system's CPU-level boot
   came from the device, e.g. /dev/ad1s1a, even if the disk is internally
   labeled as e.g. "ad0s1a", why would
   not the loader just automatically assume that ad1s1a is now "the
   cheese"?
   I've looked from time to time for the writeup about this issue and have
   never been able to find it a second time.
   Thanks in advance for any clarification or references you can offer.
   -ecsd (Eric Dynamic)



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?52AD3C12.301>