Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 16 May 2015 13:11:52 -0453
From:      "William A. Mahaffey III" <wam@hiwaay.net>
To:        "FreeBSD Questions !!!!" <freebsd-questions@freebsd.org>
Subject:   pkg/ports question
Message-ID:  <555786F1.8000509@hiwaay.net>

Next in thread | Raw E-Mail | Index | Archive | Help


I am running FreeBSD 9.3R-p13 on this box, love it. I am still newish to 
the *BSD's, so I have 1 bit of puzzlement with pkg/ports. I maintain the 
box w/ pkg almost exclusively, using ports only for browser flash 
support, nothing else. I nonetheless (try to) keep my ports tree up to 
date, in case I want to play around w/ compiling stuff locally for 
better performance, etc. I commonly (not quite daily, but several time a 
week) run CLI commands to check on availability of pkg/ports upgrades, 
see below from this A.M.:


[root@kabini1, /etc, 9:18:41am] 372 % pkg version -vRL=
Updating FreeBSD repository catalogue...
Fetching meta.txz: 100%    968 B   1.0kB/s    00:01
Fetching packagesite.txz: 100%    5 MiB 355.3kB/s    00:15
Processing entries: 100%
FreeBSD repository update completed. 23971 packages processed.
GeoIP-1.6.5                        <   needs updating (remote has 1.6.5_2)
ImageMagick-6.9.1.1,1              <   needs updating (remote has 6.9.1.2,1)
Thunar-1.6.6_2                     <   needs updating (remote has 1.6.8)
bitmap-1.0.7                       <   needs updating (remote has 1.0.8)
boost-libs-1.55.0_4                <   needs updating (remote has 1.55.0_5)
bootstrap-openjdk-r351880          <   needs updating (remote has r351880_1)
ca_root_nss-3.18                   <   needs updating (remote has 3.19)
cblas-1.0_3                        <   needs updating (remote has 1.0_4)
colord-1.2.4                       <   needs updating (remote has 1.2.4_1)
curl-7.41.0                        <   needs updating (remote has 7.42.1)
firefox-37.0.1,1                   <   needs updating (remote has 38.0,1)
font-util-1.3.0_2                  <   needs updating (remote has 1.3.1)
gcc-4.8.4_1                        <   needs updating (remote has 4.8.4_3)
git-2.3.5                          <   needs updating (remote has 2.4.0)
gnupg-2.1.2                        <   needs updating (remote has 2.1.2_1)
gnutls-3.2.21                      <   needs updating (remote has 3.2.21_1)
gstreamer-0.10.36_2                <   needs updating (remote has 0.10.36_3)
harfbuzz-0.9.40                    <   needs updating (remote has 0.9.40_1)
iceauth-1.0.6                      <   needs updating (remote has 1.0.7)
icu-53.1                           <   needs updating (remote has 55.1)
libFS-1.0.6_1                      <   needs updating (remote has 1.0.6_2)
libICE-1.0.9,1                     <   needs updating (remote has 1.0.9_1,1)
libSM-1.2.2_2,1                    <   needs updating (remote has 1.2.2_3,1)
libX11-1.6.2_2,1                   <   needs updating (remote has 1.6.2_3,1)
libXScrnSaver-1.2.2_2              <   needs updating (remote has 1.2.2_3)
libXTrap-1.0.1_2                   <   needs updating (remote has 1.0.1_3)
libXau-1.0.8_2                     <   needs updating (remote has 1.0.8_3)
libXaw-1.0.12_2,2                  <   needs updating (remote has 
1.0.12_3,2)
libXcomposite-0.4.4_2,1            <   needs updating (remote has 0.4.4_3,1)
libXcursor-1.1.14_2                <   needs updating (remote has 1.1.14_3)
libXdamage-1.1.4_2                 <   needs updating (remote has 1.1.4_3)
libXdmcp-1.1.1_2                   <   needs updating (remote has 1.1.2)
libXevie-1.0.3_2                   <   needs updating (remote has 1.0.3_3)
libXext-1.3.3,1                    <   needs updating (remote has 1.3.3_1,1)
libXfixes-5.0.1_2                  <   needs updating (remote has 5.0.1_3)
libXfontcache-1.0.5_2              <   needs updating (remote has 1.0.5_3)
libXft-2.3.2                       <   needs updating (remote has 2.3.2_1)
libXi-1.7.4,1                      <   needs updating (remote has 1.7.4_1,1)
libXinerama-1.1.3_2,1              <   needs updating (remote has 1.1.3_3,1)
libXmu-1.1.2_2,1                   <   needs updating (remote has 1.1.2_3,1)
libXp-1.0.2_2,1                    <   needs updating (remote has 1.0.3,1)
libXpm-3.5.11_2                    <   needs updating (remote has 3.5.11_3)
libXrandr-1.4.2_2                  <   needs updating (remote has 1.4.2_3)
libXrender-0.9.8_2                 <   needs updating (remote has 0.9.8_3)
libXres-1.0.7_2                    <   needs updating (remote has 1.0.7_3)
libXt-1.1.4_2,1                    <   needs updating (remote has 1.1.4_3,1)
libXtst-1.2.2_2                    <   needs updating (remote has 1.2.2_3)
libXv-1.0.10_2,1                   <   needs updating (remote has 
1.0.10_3,1)
libXvMC-1.0.8_2                    <   needs updating (remote has 1.0.9)
libXxf86dga-1.1.4_2                <   needs updating (remote has 1.1.4_3)
libXxf86misc-1.0.3_2               <   needs updating (remote has 1.0.3_3)
libXxf86vm-1.1.3_2                 <   needs updating (remote has 1.1.4)
libcdr-0.0.16_2                    ?   orphaned: graphics/libcdr
libcdr01-0.1.1                     <   needs updating (remote has 0.1.1_1)
libdmx-1.1.3_2                     <   needs updating (remote has 1.1.3_3)
libdrm-2.4.58_1,1                  <   needs updating (remote has 2.4.60,1)
libe-book-0.1.2                    <   needs updating (remote has 0.1.2_1)
libe-book00-0.0.3                  <   needs updating (remote has 0.0.3_1)
libedit-3.1.20150325               <   needs updating (remote has 
3.1.20150325_1)
libetonyek-0.0.4_1                 ?   orphaned: graphics/libetonyek
libfontenc-1.1.2_2                 <   needs updating (remote has 1.1.2_3)
libfreehand00-0.0.0                ?   orphaned: graphics/libfreehand00
libgpg-error-1.17                  <   needs updating (remote has 1.19)
libgsf-1.14.32                     <   needs updating (remote has 1.14.33)
libiconv-1.14_6                    <   needs updating (remote has 1.14_8)
libksba-1.3.2                      <   needs updating (remote has 1.3.3)
libmspub-0.0.6_3                   ?   orphaned: print/libmspub
libmspub01-0.1.2                   <   needs updating (remote has 0.1.2_1)
libmwaw-0.2.0_1                    ?   orphaned: textproc/libmwaw
libodfgen-0.0.4_3                  ?   orphaned: textproc/libodfgen
liboldX-1.0.1_2                    <   needs updating (remote has 1.0.1_3)
liborcus-0.5.2_1                   <   needs updating (remote has 0.9.0)
liborcus07-0.7.0                   <   needs updating (remote has 0.7.1)
libpciaccess-0.13.2_2              <   needs updating (remote has 0.13.3)
libreoffice-4.3.6                  <   needs updating (remote has 4.3.7)
libtasn1-4.2                       <   needs updating (remote has 4.5)
libtorrent-rasterbar-0.16.19       <   needs updating (remote has 0.16.19_1)
libvisio-0.0.31_3                  <   needs updating (remote has 0.0.31_4)
libvisio01-0.1.1                   <   needs updating (remote has 0.1.1_1)
libxcb-1.11                        <   needs updating (remote has 1.11_1)
libxkbfile-1.0.8_2                 <   needs updating (remote has 1.0.8_3)
libxkbui-1.0.2_3                   <   needs updating (remote has 1.0.2_4)
libxshmfence-1.1_3                 <   needs updating (remote has 1.2)
libxul-31.6.0                      <   needs updating (remote has 31.7.0)
linux-c6-flashplugin-11.2r202.451_1 ?   orphaned: www/linux-c6-flashplugin11
linux_base-c6-6.6_3                <   needs updating (remote has 6.6_4)
mDNSResponder-561.1.1              <   needs updating (remote has 567)
mkfontscale-1.1.1_1                <   needs updating (remote has 1.1.2)
mplayer-1.1.r20150403              <   needs updating (remote has 
1.1.r20150403_1)
mysql56-client-5.6.23              <   needs updating (remote has 5.6.24)
npth-1.1                           <   needs updating (remote has 1.2)
nspr-4.10.8                        <   needs updating (remote has 4.10.8_1)
nss-3.18                           <   needs updating (remote has 3.19)
openblas-0.2.13,1                  <   needs updating (remote has 0.2.14,1)
opencv-core-2.4.9_1                <   needs updating (remote has 2.4.9_2)
openjdk-7.76.13_1,1                <   needs updating (remote has 7.80.15,1)
openssl-1.0.2                      <   needs updating (remote has 1.0.2_1)
p11-kit-0.22.1                     <   needs updating (remote has 0.23.1)
p5-Socket-2.018                    <   needs updating (remote has 2.019)
pciids-20150404                    <   needs updating (remote has 20150428)
perl5-5.18.4_12                    <   needs updating (remote has 5.18.4_14)
php56-5.6.7                        <   needs updating (remote has 5.6.8)
php56-json-5.6.7                   <   needs updating (remote has 5.6.8)
php56-mysql-5.6.7                  <   needs updating (remote has 5.6.8)
php56-session-5.6.7                <   needs updating (remote has 5.6.8)
pixman-0.32.6                      <   needs updating (remote has 0.32.6_1)
pkgconf-0.9.8                      <   needs updating (remote has 0.9.10)
png-1.6.16                         <   needs updating (remote has 1.6.17)
py27-cryptography-0.7.2            <   needs updating (remote has 0.8.2)
py27-libtorrent-rasterbar-0.16.19  <   needs updating (remote has 0.16.19_1)
py27-twistedCore-15.0.0_1          <   needs updating (remote has 15.1.0)
py27-twistedWeb-15.0.0             <   needs updating (remote has 15.1.0)
qemu-devel-2.2.1                   <   needs updating (remote has 2.3.0)
qt4-corelib-4.8.6_3                <   needs updating (remote has 4.8.6_5)
qt4-gui-4.8.6_4                    <   needs updating (remote has 4.8.6_5)
randrproto-1.4.0                   <   needs updating (remote has 1.4.1)
raptor2-2.0.15                     <   needs updating (remote has 2.0.15_1)
ruby-2.1.5_4,1                     <   needs updating (remote has 2.1.6,1)
sessreg-1.0.8                      <   needs updating (remote has 1.1.0)
sqlite3-3.8.8.3                    <   needs updating (remote has 3.8.10.1)
talloc-2.1.1                       <   needs updating (remote has 2.1.2)
tcpdump-4.7.3                      <   needs updating (remote has 4.7.4)
texlive-base-20140525_6            <   needs updating (remote has 
20140525_7)
thunderbird-31.6.0                 <   needs updating (remote has 31.7.0)
xcb-util-0.4.0,1                   <   needs updating (remote has 0.4.0_1,1)
xcb-util-renderutil-0.3.9          <   needs updating (remote has 0.3.9_1)
xf86-input-mouse-1.9.0_6           <   needs updating (remote has 1.9.1)
xf86-video-intel-2.21.15_7         <   needs updating (remote has 2.21.15_8)
xkbcomp-1.2.4                      <   needs updating (remote has 1.3.0)
xkeyboard-config-2.13              <   needs updating (remote has 2.14)
xproto-7.0.26                      <   needs updating (remote has 7.0.27)
xterm-317                          <   needs updating (remote has 318)
  whew !!!! that took (15.458 cpu + 1.538 sys) sec., 0:33.20 elapsed 
time tot, 51.1% CPU efficiency
         (208 text, 2561 data, 30196 max) KB, (0+788) io, 7492 pfs + 0 swaps
You have new mail.
[root@kabini1, /etc, 12:59:26pm] 373 % pkg version -vRL= | wc -l
      135
[root@kabini1, /etc, 12:59:36pm] 374 %


and for ports, straight off of the man page:


[root@kabini1, /etc, 12:59:44pm] 335 % portmaster -L | egrep -B1 
'(ew|ort) 
version|Aborting|installed|dependencies|IGNORE|marked|Reason:|MOVED|deleted|exist|update' 
| grep -v '^--'
===>>> Root ports (No dependencies, not depended on)
===>>> kqemu-kmod-1.3.0.p11_12
         ===>>> This port is marked IGNORE

===>>> Trunk ports (No dependencies, are depended on)
===>>> drm-kmod-9.280208
         ===>>> This port is marked IGNORE
===>>> fusefs-kmod-0.263233_1,1
         ===>>> This port is marked IGNORE
===>>> lsof-4.89.d,8
         ===>>> This port is marked IGNORE

===>>> Branch ports (Have dependencies, are depended on)
===>>> gtk-engines2-2.20.2_2
===>>> gtk-update-icon-cache-2.24.27
         ===>>> The graphics/libetonyek port moved to graphics/libetonyek01
         ===>>> Reason: Replaced by newer version

===>>> Leaf ports (Have dependencies, not depended on)
         ===>>> The graphics/libcdr port moved to graphics/libcdr01
         ===>>> Reason: Replaced by newer version
         ===>>> The graphics/libfreehand00 port moved to 
graphics/libfreehand
         ===>>> Reason: Replaced by newer version
         ===>>> The print/libmspub port moved to print/libmspub01
         ===>>> Reason: Replaced by newer version
         ===>>> The textproc/libmwaw port moved to textproc/libmwaw03
         ===>>> Reason: Replaced by newer version
         ===>>> The textproc/libodfgen port moved to textproc/libodfgen01
         ===>>> Reason: Replaced by newer version

===>>> 788 total installed ports
         ===>>> There are no new versions available
  whew !!!! that took (190.323 cpu + 51.471 sys) sec., 3:58.67 elapsed 
time tot, 101.3% CPU efficiency
         (743 text, 2076 data, 16992 max) KB, (0+0) io, 0 pfs + 0 swaps
[root@kabini1, /etc, 1:03:44pm] 335 %


We see about 125 pkg's w/ upgrades available, but no ports. I thought 
pkg's were made from ports, thus if there were/are new pkg's, there 
ought to be (approximately) corresponding new ports, no ? This is *not* 
a serious issue, BTW, just a matter of my understanding being a bit off, 
so I am just looking for clarification. TIA & have a nice weekend :-) ....


-- 

	William A. Mahaffey III

  ----------------------------------------------------------------------

	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?555786F1.8000509>