Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 12 Apr 2012 21:13:30 -0600 (MDT)
From:      Warren Block <wblock@wonkity.com>
To:        Florian Unglaub <ueber@roladder.net>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Intel turbo mode support
Message-ID:  <alpine.BSF.2.00.1204122103360.1978@wonkity.com>
In-Reply-To: <4F85FF2E.3000309@roladder.net>
References:  <4F85FF2E.3000309@roladder.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Thu, 12 Apr 2012, Florian Unglaub wrote:

> I've stumbled upon http://goo.gl/Aq6Vd in the freebsd-current mailling list 
> and started investigating if turbo mode is working on my i7 860 here. The CPU 
> stock frequency is 2.8GHZ which is the maximum that dev.cpu.0.freq_levels 
> reports (powerd is enabled). According to the link above, freq_levels should 
> show a maximum frequency of 2801 if turbo mode is working.
>
> The patch above was MFC'ed quite a while ago. I updated to 9-stable yesterday 
> and it looks like the turbo is not working. dev.cpu.0.freq is at max. 2.8GHz, 
> even if I am using some CPU stress testing utilities (like burnP6).

Works here on an i5, amd64:

dev.cpu.0.freq_levels: 5801/300000 5800/300000

I found this by accident, noticing only that a buildworld suddenly was a 
lot faster when powerd was running.

powerd_enable="YES"
powerd_flags="-a hadp -n hadp"
performance_cpu_freq="HIGH"

During a buildworld, dev.cpu.0.freq goes to 5801.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1204122103360.1978>