Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 04 Mar 2012 21:31:00 +0100
From:      =?ISO-8859-1?Q?Erik_N=F8rgaard?= <norgaard@locolomo.org>
To:        freebsd-questions@freebsd.org
Subject:   Re: Running OS tftp vs. pxeboot tftp
Message-ID:  <4F53D104.6060104@locolomo.org>
In-Reply-To: <CAHzLAVGCiYYx-EzAWUR63KEFvyC5-RMGzAFn7kVrYKzKgPVSnA@mail.gmail.com>
References:  <CAHzLAVGCiYYx-EzAWUR63KEFvyC5-RMGzAFn7kVrYKzKgPVSnA@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 01/03/2012 16:16, Rick Miller wrote:
> Hi All,
>
> Are there significant differences in the implementation between the
> tftp client in FreeBSD 8.2-RELEASE and the client implementation in
> pxeboot.bs?

I have no reason to believe there should be any difference. If you 
believe there is a problem with the supplied pxeboot, you can compile 
your own.

You previusly wrote about VLAN tagging for your pxeboot nodes, but never 
wrote back if you solved the problem. What's your setup?

> I ask because I have encountered a scenario where pxeboot.bs is
> tftp'ing boot files from a PXE server and fails in random spots while
> attempting to download boot files to start a 8.2-RELEASE install.
> When we run the same sequence of tftp gets in a running 8.2-RELEASE
> instance continuously, we never received a single failure in a solid
> hour of attempts.

You should have some log or other traces to debug on the problem, can't 
help much without.

BR, Erik

-- 
M: +34 666 334 818
T: +34 915 211 157



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F53D104.6060104>