Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 17 Mar 2009 20:25:21 +0100 (CET)
From:      Joerg Pulz <Joerg.Pulz@frm2.tum.de>
To:        Andrea Venturoli <ml@netfence.it>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Fujitsu Siemens Promergy RX100S4
Message-ID:  <alpine.BSF.2.00.0903172014000.2287@unqrf.nqzva.sez2>
In-Reply-To: <49BF7E71.6020507@netfence.it>
References:  <49BF7E71.6020507@netfence.it>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


On Tue, 17 Mar 2009, Andrea Venturoli wrote:

> Anyone tried 7.1/amd64 on this?
>
> I have two SATA disks configured for mirroring in the BIOS; I see the two 
> disks separately as ad devices, but no RAID device: I'd expect an ar0 or 
> something.
>
> Is this card not supported?

I've two of these here, both running 7.0 one as i386 and one as amd64.
The amd64 box uses the onboard RAID.

Here are the relevant dmesg parts:
- ----
atapci0: <Intel ICH7 UDMA100 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x37
6,0x3420-0x342f at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
atapci1: <Intel AHCI controller> port 
0x3440-0x3447,0x3434-0x3437,0x3438-0x343f,
0x3430-0x3433,0x3400-0x341f mem 0xfd000400-0xfd0007ff irq 19 at device 
31.2 on p
ci0
atapci1: [ITHREAD]
atapci1: AHCI Version 01.10 controller with 4 ports detected
ata2: <ATA channel 0> on atapci1
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci1
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci1
ata4: port not implemented
ata4: [ITHREAD]
ata5: <ATA channel 3> on atapci1
ata5: port not implemented
ata5: [ITHREAD]

acd0: CDRW <HL-DT-STCD-RW/DVD DRIVE GCC-4244N/1.00> at ata0-master UDMA33
ad4: 238475MB <WDC WD2500JS-55NCB1 10.02E01> at ata2-master SATA300
ad6: 238475MB <WDC WD2500JS-55NCB1 10.02E01> at ata3-master SATA300

ar0: 238475MB <Intel MatrixRAID RAID1> status: READY
ar0: disk0 READY (master) using ad4 at ata2-master
ar0: disk1 READY (mirror) using ad6 at ata3-master
- ----

If i remeber correctly, you have to enable the RAID option in the BIOS to 
configure the two disk as array, afterwards you must enter the BIOS again 
and switch to AHCI. As the ataraid driver detects the array by reading the 
metadata on the disks it should detect the array. I'm not 100 percent sure 
but i think this is the way i did it.

pciconf -lv show the following for the atapci device (again there is AHCI 
mentioned in the output):
- ----
atapci0@pci0:0:31:1:    class=0x01018a card=0x10a51734 chip=0x27df8086 
rev=0x01 hdr=0x00
     vendor     = 'Intel Corporation'
     device     = '82801G (ICH7 Family) Ultra ATA Storage Controller'
     class      = mass storage
     subclass   = ATA
atapci1@pci0:0:31:2:    class=0x010601 card=0x10a51734 chip=0x27c18086 
rev=0x01 hdr=0x00
     vendor     = 'Intel Corporation'
     device     = '82801GB I/O Controller Hub SATA cc=AHCI'
     class      = mass storage
- ----

The second box (running i386) is using geom_mirror and running fine.

I would definitely vote for the geom_mirror way!

kind regards
Joerg

- -- 
The beginning is the most important part of the work.
 				-Plato
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (FreeBSD)

iD8DBQFJv/kkSPOsGF+KA+MRAlM8AKDP/wc5839XQIzQN6dnFVScAnn+4wCfS5ZA
p2H8lnmtJp+R6VkvwS2LOJY=
=y1Nz
-----END PGP SIGNATURE-----



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.0903172014000.2287>