Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 13 Apr 2012 11:50:39 +0700
From:      Erich Dollansky <erichfreebsdlist@ovitrap.com>
To:        freebsd-questions@freebsd.org
Cc:        "Conrad J. Sabatier" <conrads@cox.net>, Gabriel Marchi <gabrielmarchi@bsd.com.br>
Subject:   Re: Xorg doesn't go back correctly to console when closed on FreeBSD 9.0
Message-ID:  <201204131150.39410.erichfreebsdlist@ovitrap.com>
In-Reply-To: <20120412211022.74f93236@cox.net>
References:  <CALPonDfXgBG3_EnBqvqa=3HCZ1B6uORj+HvNG3ffOVfwjKRQUA@mail.gmail.com> <20120412211022.74f93236@cox.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi,

On Friday 13 April 2012 09:10:22 Conrad J. Sabatier wrote:
> On Thu, 12 Apr 2012 10:13:00 -0300
> Gabriel Marchi <gabrielmarchi@bsd.com.br> wrote:
>=20
> > Hi all,
> > I=B4m running 9.0-RELEASE on my laptop, everything works fine, except
> > when I try go back to console I get a black screen.
> >=20
> > dmesg: http://pastebin.com/U45duS5n
> > xorg.conf: http://pastebin.com/qERavJs0
> > Xorg.0.log: http://pastebin.com/143m0gWB
> > pciconf: http://pastebin.com/ZfQ6daGC
> >=20
> > Thanks in advance.
> > Gabriel Marchi
>=20
> I've noticed this same behavior for a while now, when running X using
> xinit (startx).  Upon exiting my X session, the X server doesn't
> shutdown, but has to be manually killed.
>=20
it is the same for 8.3 and before. I have this effect since many years on d=
ifferent machines with different versions. The effect comes and goes.

What works is switching to the console startx was called, hitting control C=
 to kill X and start X again.

I do not bother much about this as I simply kill X from the calling console.

Erich



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?201204131150.39410.erichfreebsdlist>