Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 13 Apr 2012 07:24:04 +0200
From:      Matthias Apitz <guru@unixarea.de>
To:        Erich Dollansky <erichfreebsdlist@ovitrap.com>
Cc:        "Conrad J. Sabatier" <conrads@cox.net>, Gabriel Marchi <gabrielmarchi@bsd.com.br>, freebsd-questions@freebsd.org
Subject:   Re: Xorg doesn't go back correctly to console when closed on FreeBSD 9.0
Message-ID:  <20120413052404.GB2323@tinyCurrent>
In-Reply-To: <201204131150.39410.erichfreebsdlist@ovitrap.com>
References:  <CALPonDfXgBG3_EnBqvqa=3HCZ1B6uORj+HvNG3ffOVfwjKRQUA@mail.gmail.com> <20120412211022.74f93236@cox.net> <201204131150.39410.erichfreebsdlist@ovitrap.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
El día Friday, April 13, 2012 a las 11:50:39AM +0700, Erich Dollansky escribió:

> > I've noticed this same behavior for a while now, when running X using
> > xinit (startx).  Upon exiting my X session, the X server doesn't
> > shutdown, but has to be manually killed.
> > 
> it is the same for 8.3 and before. I have this effect since many years on different machines with different versions. The effect comes and goes.
> 
> What works is switching to the console startx was called, hitting control C to kill X and start X again.
> 
> I do not bother much about this as I simply kill X from the calling console.

Please show your ~/.xinitrc and ~/.xserverrc; mine look like this:

$ cat .xinitrc
setxkbmap -option terminate:ctrl_alt_bksp
exec startkde

$ cat .xserverrc 
exec X -nolisten tcp -retro

and X comes down fine when KDE ends.

HIH

	matthias

-- 
Matthias Apitz
t +49-89-61308 351 - f +49-89-61308 399 - m +49-170-4527211
e <guru@unixarea.de> - w http://www.unixarea.de/
UNIX since V7 on PDP-11 | UNIX on mainframe since ESER 1055 (IBM /370)
UNIX on x86 since SVR4.2 UnixWare 2.1.2 | FreeBSD since 2.2.5



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20120413052404.GB2323>