Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 2 Jul 2011 11:42:06 -0600 (MDT)
From:      Dennis Glatting <freebsd@penx.com>
To:        freebsd-questions@freebsd.org
Subject:   Trying to understand the mechanics of boot
Message-ID:  <alpine.BSF.2.00.1107021120001.21724@Elmer.dco.penx.com>

Next in thread | Raw E-Mail | Index | Archive | Help

I have a system with a large number of disks whose dmesg output is the 
last data component of this message, preceded by my zpool configuration 
which is preceded by my fstab.

I boot off of ad4, which is the MARVELL Raid configured for RAID1 across 
two 1TB disks. The problem I have is if I add more disks to the Areca 
adapter, which is configured JBOD, or the ICH10, which is also configured 
JBOD, the BIOS sees the RAID1 disk, selects it, but when it starts to boot 
the BIOS appears to be the entity that prints the message:

 	Reboot and Select proper boot device
 	or insert boot media in selected boot device and press a key

My motherboard is an ASUS RAMPAGE III Extreme but I have tried a different 
MB, in particular a Gigabyte board, with the same result.

I do not see any hint of FreeBSD in the boot process and therefore do not 
know if the BIOS accesses the MBR of my RAID1 array or whetehr the 
problem is the BIOS or FreeBSD boot sequence.

I do understand disk devices will move as one adds or removes disks, 
having had to edit fstab from CD boot many times previously, but I don't 
think that is the problem I am having, not to say it isn't a problem later 
in the boot sequence.

I'm stumped how to go forward with debugging this problem. It appears to 
be some limitation is reached in the BIOSes. I am hopping someone with 
much more detailed knowledge of low level boot/disk sequences can point me 
in a direction.






iirc> cat /etc/fstab
# Device                Mountpoint      FStype  Options         Dump 
Pass#
/dev/ad4s1b             none            swap    sw              0       0
/dev/ad4s1a             /               ufs     rw              1       1
/dev/acd0               /cdrom          cd9660  ro,noauto       0       0


iirc> zpool status
   pool: disk-1
  state: ONLINE
  scan: scrub repaired 0 in 1h8m with 0 errors on Sat Jul  2 04:10:41 2011
config:

         NAME        STATE     READ WRITE CKSUM
         disk-1      ONLINE       0     0     0
           raidz1-0  ONLINE       0     0     0
             da0     ONLINE       0     0     0
             da1     ONLINE       0     0     0
             da2     ONLINE       0     0     0
             da3     ONLINE       0     0     0

errors: No known data errors

   pool: disk-2
  state: ONLINE
  scan: scrub repaired 0 in 0h3m with 0 errors on Sat Jul  2 03:05:38 2011
config:

         NAME        STATE     READ WRITE CKSUM
         disk-2      ONLINE       0     0     0
           mirror-0  ONLINE       0     0     0
             ad34    ONLINE       0     0     0
             ad36    ONLINE       0     0     0
         cache
           ad20      ONLINE       0     0     0

errors: No known data errors



iirc> dmesg
Copyright (c) 1992-2011 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.2-STABLE #25: Sat Jun 25 17:34:51 PDT 2011
     root@iirc:/usr/src/sys/amd64/compile/IIRC amd64
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM) i7 CPU         940  @ 2.93GHz (2960.51-MHz K8-class 
CPU)
   Origin = "GenuineIntel"  Id = 0x106a4  Family = 6  Model = 1a  Stepping 
= 4

Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>

Features2=0x98e3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT>
   AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
   AMD Features2=0x1<LAHF>
   TSC: P-state invariant
real memory  = 12884901888 (12288 MB)
avail memory = 12371382272 (11798 MB)
ACPI APIC Table: <031711 APIC1638>
FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s) x 2 SMT threads
  cpu0 (BSP): APIC ID:  0
  cpu1 (AP): APIC ID:  1
  cpu2 (AP): APIC ID:  2
  cpu3 (AP): APIC ID:  3
  cpu4 (AP): APIC ID:  4
  cpu5 (AP): APIC ID:  5
  cpu6 (AP): APIC ID:  6
  cpu7 (AP): APIC ID:  7
ioapic0 <Version 2.0> irqs 0-23 on motherboard
ioapic1 <Version 2.0> irqs 24-47 on motherboard
kbd1 at kbdmux0
acpi0: <031711 XSDT1638> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of fee00000, 1000 (3) failed
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, bff00000 (3) failed
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
cpu4: <ACPI CPU> on acpi0
cpu5: <ACPI CPU> on acpi0
cpu6: <ACPI CPU> on acpi0
cpu7: <ACPI CPU> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
atapci0: <Marvell AHCI controller> port 
0xac00-0xac07,0xa880-0xa883,0xa800-0xa807,0xa480-0xa483,0xa400-0xa40f mem 
0xfb9ff800-0xfb9fffff irq 28 at device 0.0 on pci1
atapci0: [ITHREAD]
atapci0: AHCI v1.20 controller with 8 6Gbps ports, PM not supported
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci0
ata4: [ITHREAD]
ata5: <ATA channel 3> on atapci0
ata5: [ITHREAD]
ata6: <ATA channel 4> on atapci0
ata6: [ITHREAD]
ata7: <ATA channel 5> on atapci0
ata7: [ITHREAD]
ata8: <ATA channel 6> on atapci0
ata8: [ITHREAD]
ata9: <ATA channel 7> on atapci0
ata9: [ITHREAD]
pcib2: <ACPI PCI-PCI bridge> at device 2.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <serial bus, USB> at device 0.0 (no driver attached)
pcib3: <ACPI PCI-PCI bridge> at device 3.0 on pci0
pci3: <ACPI PCI bus> on pcib3
vgapci0: <VGA-compatible display> port 0xb000-0xb0ff mem 
0xd0000000-0xdfffffff,0xfbbe0000-0xfbbeffff irq 24 at device 0.0 on pci3
pci3: <multimedia, HDA> at device 0.1 (no driver attached)
pcib4: <ACPI PCI-PCI bridge> at device 5.0 on pci0
pci4: <ACPI PCI bus> on pcib4
arcmsr0: <Areca SAS 6G Host Adapter RAID Controller (RAID6 capable)
> port 0xc800-0xc8ff mem 0xfbcf0000-0xfbcfffff,0xfbc80000-0xfbcbffff irq 
26 at device 0.0 on pci4
ARECA RAID ADAPTER0: Driver Version 1.20.00.21 2010-03-03
ARECA RAID ADAPTER0: FIRMWARE VERSION V1.49 2010-12-10
arcmsr0: [ITHREAD]
pcib5: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci5: <ACPI PCI bus> on pcib5
pci0: <base peripheral, interrupt controller> at device 20.0 (no driver 
attached)
pci0: <base peripheral, interrupt controller> at device 20.1 (no driver 
attached)
pci0: <base peripheral, interrupt controller> at device 20.2 (no driver 
attached)
pci0: <base peripheral, interrupt controller> at device 20.3 (no driver 
attached)
em0: <Intel(R) PRO/1000 Network Connection 7.2.3> port 0x9c00-0x9c1f mem 
0xfb8e0000-0xfb8fffff,0xfb8df000-0xfb8dffff irq 20 at device 25.0 on pci0
em0: Using an MSI interrupt
em0: [FILTER]
em0: Ethernet address: f4:6d:04:01:c6:fc
uhci0: <Intel 82801JI (ICH10) USB controller USB-D> port 0x9480-0x949f irq 
16 at device 26.0 on pci0
uhci0: [ITHREAD]
uhci0: LegSup = 0x2f00
usbus0: <Intel 82801JI (ICH10) USB controller USB-D> on uhci0
uhci1: <Intel 82801JI (ICH10) USB controller USB-E> port 0x9800-0x981f irq 
21 at device 26.1 on pci0
uhci1: [ITHREAD]
uhci1: LegSup = 0x2f00
usbus1: <Intel 82801JI (ICH10) USB controller USB-E> on uhci1
uhci2: <Intel 82801JI (ICH10) USB controller USB-F> port 0x9880-0x989f irq 
19 at device 26.2 on pci0
uhci2: [ITHREAD]
uhci2: LegSup = 0x2f00
usbus2: <Intel 82801JI (ICH10) USB controller USB-F> on uhci2
ehci0: <Intel 82801JI (ICH10) USB 2.0 controller USB-B> mem 
0xfb8de000-0xfb8de3ff irq 18 at device 26.7 on pci0
ehci0: [ITHREAD]
usbus3: EHCI version 1.0
usbus3: <Intel 82801JI (ICH10) USB 2.0 controller USB-B> on ehci0
pcib6: <ACPI PCI-PCI bridge> irq 17 at device 28.0 on pci0
pci7: <ACPI PCI bus> on pcib6
pcib7: <PCI-PCI bridge> irq 16 at device 0.0 on pci7
pci8: <PCI bus> on pcib7
atapci1: <SiI 3124 SATA300 controller> port 0xec00-0xec0f mem 
0xfbeffc00-0xfbeffc7f,0xfbef0000-0xfbef7fff irq 16 at device 0.0 on pci8
atapci1: [ITHREAD]
ata10: <ATA channel 0> on atapci1
ata10: [ITHREAD]
ata11: <ATA channel 1> on atapci1
ata11: [ITHREAD]
ata12: <ATA channel 2> on atapci1
ata12: [ITHREAD]
ata13: <ATA channel 3> on atapci1
ata13: [ITHREAD]
pcib8: <ACPI PCI-PCI bridge> irq 17 at device 28.4 on pci0
pci6: <ACPI PCI bus> on pcib8
atapci2: <JMicron JMB363 UDMA133 controller> port 
0xdc00-0xdc07,0xd880-0xd883,0xd800-0xd807,0xd480-0xd483,0xd400-0xd40f mem 
0xfbdfe000-0xfbdfffff irq 16 at device 0.0 on pci6
atapci2: [ITHREAD]
atapci3: <AHCI SATA controller> on atapci2
atapci3: [ITHREAD]
atapci3: AHCI v1.00 controller with 2 3Gbps ports, PM supported
ata14: <ATA channel 0> on atapci3
ata14: [ITHREAD]
ata15: <ATA channel 1> on atapci3
ata15: [ITHREAD]
ata16: <ATA channel 0> on atapci2
ata16: [ITHREAD]
uhci3: <Intel 82801JI (ICH10) USB controller USB-A> port 0x9000-0x901f irq 
23 at device 29.0 on pci0
uhci3: [ITHREAD]
uhci3: LegSup = 0x2f00
usbus4: <Intel 82801JI (ICH10) USB controller USB-A> on uhci3
uhci4: <Intel 82801JI (ICH10) USB controller USB-B> port 0x9080-0x909f irq 
19 at device 29.1 on pci0
uhci4: [ITHREAD]
uhci4: LegSup = 0x2f00
usbus5: <Intel 82801JI (ICH10) USB controller USB-B> on uhci4
uhci5: <Intel 82801JI (ICH10) USB controller USB-C> port 0x9400-0x941f irq 
18 at device 29.2 on pci0
uhci5: [ITHREAD]
uhci5: LegSup = 0x2f00
usbus6: <Intel 82801JI (ICH10) USB controller USB-C> on uhci5
ehci1: <Intel 82801JI (ICH10) USB 2.0 controller USB-A> mem 
0xfb8dd000-0xfb8dd3ff irq 23 at device 29.7 on pci0
ehci1: [ITHREAD]
usbus7: EHCI version 1.0
usbus7: <Intel 82801JI (ICH10) USB 2.0 controller USB-A> on ehci1
pcib9: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci9: <ACPI PCI bus> on pcib9
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci4: <Intel ICH10 SATA300 controller> port 
0x8880-0x8887,0x8800-0x8803,0x8480-0x8487,0x8400-0x8403,0x8080-0x809f mem 
0xfb8db000-0xfb8db7ff irq 20 at device 31.2 on pci0
atapci4: [ITHREAD]
atapci4: AHCI called from vendor specific driver
atapci4: AHCI v1.20 controller with 6 3Gbps ports, PM supported
ata17: <ATA channel 0> on atapci4
ata17: [ITHREAD]
ata18: <ATA channel 1> on atapci4
ata18: [ITHREAD]
ata19: <ATA channel 2> on atapci4
ata19: [ITHREAD]
ata20: <ATA channel 3> on atapci4
ata20: [ITHREAD]
ata21: <ATA channel 4> on atapci4
ata21: [ITHREAD]
ata22: <ATA channel 5> on atapci4
ata22: [ITHREAD]
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_button0: <Power Button> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on 
acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
qpi0: <QPI system bus> on motherboard
pcib10: <QPI Host-PCI bridge> pcibus 255 on qpi0
pci255: <PCI bus> on pcib10
orm0: <ISA Option ROMs> at iomem 
0xd0000-0xd4fff,0xd5000-0xd7fff,0xd9800-0xdc7ff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
ppc0: cannot reserve I/O port range
coretemp0: <CPU On-Die Thermal Sensors> on cpu0
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
coretemp1: <CPU On-Die Thermal Sensors> on cpu1
est1: <Enhanced SpeedStep Frequency Control> on cpu1
p4tcc1: <CPU Frequency Thermal Control> on cpu1
coretemp2: <CPU On-Die Thermal Sensors> on cpu2
est2: <Enhanced SpeedStep Frequency Control> on cpu2
p4tcc2: <CPU Frequency Thermal Control> on cpu2
coretemp3: <CPU On-Die Thermal Sensors> on cpu3
est3: <Enhanced SpeedStep Frequency Control> on cpu3
p4tcc3: <CPU Frequency Thermal Control> on cpu3
coretemp4: <CPU On-Die Thermal Sensors> on cpu4
est4: <Enhanced SpeedStep Frequency Control> on cpu4
p4tcc4: <CPU Frequency Thermal Control> on cpu4
coretemp5: <CPU On-Die Thermal Sensors> on cpu5
est5: <Enhanced SpeedStep Frequency Control> on cpu5
p4tcc5: <CPU Frequency Thermal Control> on cpu5
coretemp6: <CPU On-Die Thermal Sensors> on cpu6
est6: <Enhanced SpeedStep Frequency Control> on cpu6
p4tcc6: <CPU Frequency Thermal Control> on cpu6
coretemp7: <CPU On-Die Thermal Sensors> on cpu7
est7: <Enhanced SpeedStep Frequency Control> on cpu7
p4tcc7: <CPU Frequency Thermal Control> on cpu7
Timecounters tick every 1.000 msec
vboxdrv: fAsync=0 offMin=0x32c offMax=0x56c
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
usbus3: 480Mbps High Speed USB v2.0
usbus4: 12Mbps Full Speed USB v1.0
usbus5: 12Mbps Full Speed USB v1.0
usbus6: 12Mbps Full Speed USB v1.0
usbus7: 480Mbps High Speed USB v2.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <Intel> at usbus2
uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
ugen3.1: <Intel> at usbus3
uhub3: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus3
ugen4.1: <Intel> at usbus4
uhub4: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus4
ugen5.1: <Intel> at usbus5
uhub5: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus5
ugen6.1: <Intel> at usbus6
uhub6: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus6
ugen7.1: <Intel> at usbus7
uhub7: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus7
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub4: 2 ports with 2 removable, self powered
uhub5: 2 ports with 2 removable, self powered
uhub6: 2 ports with 2 removable, self powered
ad4: 1906688MB <MARVELL Raid VD 0 MV.R00-0> at ata2-master UDMA100 SATA 
1.5Gb/s
ad20: 57241MB <OCZ REVODRIVE 1.20> at ata10-master UDMA100 SATA 3Gb/s
ad22: 57241MB <OCZ REVODRIVE 1.20> at ata11-master UDMA100 SATA 3Gb/s
acd0: DVDR <HL-DT-ST BD-RE BH10LS30/1.00> at ata15-master UDMA100 SATA 
1.5Gb/s
ad34: 1907729MB <Seagate ST32000542AS CC34> at ata17-master UDMA100 SATA 
3Gb/s
ad36: 1907729MB <Seagate ST32000542AS CC34> at ata18-master UDMA100 SATA 
3Gb/s
ad38: 1907729MB <Seagate ST32000542AS CC34> at ata19-master UDMA100 SATA 
3Gb/s
ad40: 1907729MB <Seagate ST32000542AS CC34> at ata20-master UDMA100 SATA 
3Gb/s
uhub3: 6 ports with 6 removable, self powered
uhub7: 6 ports with 6 removable, self powered
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00 sks=0x40 0x00 
0x01
(probe18:ata15:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
(probe18:ata15:0:0:0): CAM status: SCSI Status Error
(probe18:ata15:0:0:0): SCSI status: Check Condition
(probe18:ata15:0:0:0): SCSI sense: NOT READY asc:3a,1 (Medium not present 
- tray closed)
da0 at arcmsr0 bus 0 scbus0 target 0 lun 0
da0: <Seagate ST32000542AS R001> Fixed Direct Access SCSI-5 device
da0: 166.666MB/s transfers (83.333MHz DT, offset 32, 16bit)
da0: Command Queueing enabled
da0: 1907729MB (3907029168 512 byte sectors: 255H 63S/T 243201C)
da1 at arcmsr0 bus 0 scbus0 target 0 lun 1
da1: <Seagate ST32000542AS R001> Fixed Direct Access SCSI-5 device
da1: 166.666MB/s transfers (83.333MHz DT, offset 32, 16bit)
da1: Command Queueing enabled
da1: 1907729MB (3907029168 512 byte sectors: 255H 63S/T 243201C)
da2 at arcmsr0 bus 0 scbus0 target 0 lun 2
da2: <Seagate ST32000542AS R001> Fixed Direct Access SCSI-5 device
da2: 166.666MB/s transfers (83.333MHz DT, offset 32, 16bit)
da2: Command Queueing enabled
da2: 1907729MB (3907029168 512 byte sectors: 255H 63S/T 243201C)
da3 at arcmsr0 bus 0 scbus0 target 0 lun 3
da3: <Seagate ST32000542AS R001> Fixed Direct Access SCSI-5 device
da3: 166.666MB/s transfers (83.333MHz DT, offset 32, 16bit)
da3: Command Queueing enabled
da3: 1907729MB (3907029168 512 byte sectors: 255H 63S/T 243201C)
da4 at arcmsr0 bus 0 scbus0 target 0 lun 4
da4: <Seagate ST32000542AS R001> Fixed Direct Access SCSI-5 device
da4: 166.666MB/s transfers (83.333MHz DT, offset 32, 16bit)
da4: Command Queueing enabled
da4: 1907729MB (3907029168 512 byte sectors: 255H 63S/T 243201C)
da5 at arcmsr0 bus 0 scbus0 target 0 lun 5
da5: <Seagate ST32000542AS R001> Fixed Direct Access SCSI-5 device
da5: 166.666MB/s transfers (83.333MHz DT, offset 32, 16bit)
da5: Command Queueing enabled
da5: 1907729MB (3907029168 512 byte sectors: 255H 63S/T 243201C)
pass6 at arcmsr0 bus 0 scbus0 target 16 lun 0
pass6: <Areca RAID controller R001> Fixed Processor SCSI-0 device
SMP: AP CPU #1 Launched!
SMP: AP CPU #5 Launched!
SMP: AP CPU #3 Launched!
SMP: AP CPU #7 Launched!
SMP: AP CPU #4 Launched!
SMP: AP CPU #6 Launched!
cd0 at ata15 bus 0 scbus5 target 0 lun 0
cd0: <HL-DT-ST BD-RE  BH10LS30 1.00> Removable CD-ROM SCSI-0 device SMP: 
AP CPU #2 Launched!
cd0: 100.000MB/s transfers

cd0: Attempt to query device size failed: NOT READY, Medium not present - 
tray closed
Trying to mount root from ufs:/dev/ad4s1a
ugen6.2: <Microsoft> at usbus6
ums0: <Microsoft Microsoft 3-Button Mouse with IntelliEyeTM, class 0/0, 
rev 1.10/3.00, addr 2> on usbus6
ums0: 3 buttons and [XYZ] coordinates ID=0
ugen5.2: <vendor 0x0a12> at usbus5
ZFS filesystem version 5
ZFS storage pool version 28
ugen6.3: <CHESEN> at usbus6
ukbd0: <CHESEN USB Keyboard, class 0/0, rev 1.10/1.10, addr 3> on usbus6
kbd2 at ukbd0
uhid0: <CHESEN USB Keyboard, class 0/0, rev 1.10/1.10, addr 3> on usbus6
vboxnet0: Ethernet address: 0a:00:27:00:00:00
em0: link state changed to UP
drm0: <ATI Radeon 4800 Series> on vgapci0
info: [drm] MSI enabled 1 message(s)
info: [drm] Initialized radeon 1.31.0 20080613




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1107021120001.21724>