Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 3 Feb 2009 23:40:35 -0800
From:      James Strother <jstrother9109@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   wireless card won't associate
Message-ID:  <4b2381fb0902032340w1f9b4f04ye892aef1a2226b57@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello,

I've been trying to get a wireless card of mine working with a new install
of freebsd 7.1, but I've been unable to associate with the access point.

>From pciconf -lv, it appears the chipset is Ralink RT2561/RT61.  The
documentation for ral doesn't mention this particular chipset, but
there seems to be a consensus on various forums that this chipset is
supported by ral.

I've added the following lines to /boot/loader.conf:
if_ral_load="YES"
wlan_scan_ap_load="YES"
wlan_scan_sta_load="YES"
wlan_wep_load="YES"

And am using the following ifconfig command
ifconfig ral0 ssid <MYSSID> authmod shared wepmode on \
  deftxkey 1 wepkey 1:<MYKEY>

But ifconfig shows status as "no carrier."  The authentication is
all correct (I've triple checked everything, and am using the
same authentication on a linux laptop).  The signal strength
should be fine (the box was previously running linux, with very
good signal strength).

When I ran wlandebug -i ral0 +scan+auth+assoc the only
error I receive is: "shared key auth failed (reason 15)"

At this point I'm stymied.  Any help would be very much
appreciated.

Thanks,
   Jim



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4b2381fb0902032340w1f9b4f04ye892aef1a2226b57>