Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 24 Mar 2013 13:02:55 +0100
From:      kaltheat@googlemail.com
To:        Mark Felder <feld@feld.me>
Cc:        freebsd-questions@FreeBSD.org
Subject:   Re: snd_hda and front headphones jack
Message-ID:  <20130324120255.GA2988@sol>
In-Reply-To: <op.wtt6bbht34t2sn@markf.office.supranet.net>
References:  <op.wtt6bbht34t2sn@markf.office.supranet.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, Mar 12, 2013 at 08:55:49AM -0500, Mark Felder wrote:
> Hi guys,
> 
> I seem to be having problems getting my front headphones jack to work.  
> I've read the snd_hda man page and perhaps I'm doing this wrong, but  
> here's my setup:
> 
> ... 
> 
> If I am looking at this right I believe I need to set nid25 to as=1 which  
> matches the nid31 Speaker and probably also set seq=15. However, this  
> doesn't seem to be working. Am I overlooking something obvious?
> 
> 
> Thanks
> 

Hi,

in my setup I disabled all pins referring to "Unknown" and I disabled pins I 
don't need by setting as=0 without having any issues. I put Headphones and 
Speaker in same association (anything between 0 and 15, not 0, not 15), then I 
gave Headphones seq=15 and Speaker seq=14. As mentioned in manpage seq=15 for 
headphones will duplicate first pin in association, that would be Speaker. If I 
remember correctly online reconfiguring of device using dev.hdaa.*.reconfig 
sysctl-variable produced in some cases different devices than rebooting system 
with same changes of default configuration in device.hints.

Regards,
kaltheat





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20130324120255.GA2988>