Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 26 Jan 2011 20:34:50 +0330
From:      Bahman Kahinpour <bahman.linux@gmail.com>
To:        freebsd-questions@freebsd.org, freebsd-ports@freebsd.org
Subject:   HPLIP 3.10.9 problems on FreeBSD 8.1
Message-ID:  <AANLkTi=yV2f_fK+MvNQUmX9Qehndgbs4vWWY_BQ0r7Ky@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi FreeBSD people,
I am trying to make my HP LaserJet P1102 work on FreeBSD 8.1 and
towards that goal I installed HPLIP 3.10.9 from the Ports Collection.
But there are two problems:
1.First, when I try to run HPLIP in the GUI (GNOME), it closes once
it's opened. It remains open for less than a second.
2.Second, it does not recognize my printer. When I use the
command-line tools it just simply does not recognize my printer. This
is while the printer is recognized on the USB bus, I confirm it by
using "usbconfig".

mail# uname -a
FreeBSD mail.freebsdsystem.net 8.1-RELEASE FreeBSD 8.1-RELEASE #0: Mon
Jan 24 23:09:14 IRST 2011
root@mail.freebsdsystem.net:/usr/obj/usr/src/sys/GENERIC  i386
mail# usbconfig
ugen0.1: <EHCI root HUB Intel> at usbus0, cfg=0 md=HOST spd=HIGH
(480Mbps) pwr=ON
ugen1.1: <EHCI root HUB Intel> at usbus1, cfg=0 md=HOST spd=HIGH
(480Mbps) pwr=ON
ugen0.2: <product 0x0020 vendor 0x8087> at usbus0, cfg=0 md=HOST
spd=HIGH (480Mbps) pwr=SAVE
ugen1.2: <product 0x0020 vendor 0x8087> at usbus1, cfg=0 md=HOST
spd=HIGH (480Mbps) pwr=SAVE
ugen1.3: <Optical Mouse Genius> at usbus1, cfg=0 md=HOST spd=LOW
(1.5Mbps) pwr=ON
ugen1.4: <HID Keyboard Device vendor 0x0e6a> at usbus1, cfg=0 md=HOST
spd=LOW (1.5Mbps) pwr=ON
ugen1.5: <HP LaserJet Professional P1102 Hewlett-Packard> at usbus1,
cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
mail#

Can you give me a little help? Has anyone ever managed to get this
printer (HP P1102) working on FreeBSD?

Good Luck



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?AANLkTi=yV2f_fK+MvNQUmX9Qehndgbs4vWWY_BQ0r7Ky>