Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 17 Nov 2005 00:14:57 +0200
From:      Andy Fawcett <andy@athame.co.uk>
To:        freebsd-stable@freebsd.org
Cc:        freebsd-x11@freebsd.org, James Long <james_mapson@umpquanet.com>, x11@freebsd.org
Subject:   Re: xorg-clients conflicts with xterm (patch)
Message-ID:  <200511170014.58776.andy@athame.co.uk>
In-Reply-To: <200511170002.14208.andy@athame.co.uk>
References:  <20051116032616.GA92903@ns.museum.rain.com> <200511162226.38335.dejan.lesjak@ijs.si> <200511170002.14208.andy@athame.co.uk>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Argh! Correction below.

On Thursday 17 November 2005 00:02, Andy Fawcett wrote:
> On Wednesday 16 November 2005 23:26, Dejan Lesjak wrote:
> > On Wednesday 16 of November 2005 04:26, James Long wrote:
> > > After hours of head-banging over the past couple of days,
> > > I have finally succeeded in installing EITHER
> > > xorg-clients-6.8.2_1 OR xterm-206_1.  Previously,
> > > installing either port told me that it conflicted
> > > with the other, in spite of having cvsupped my
> > > ports tree twice to ensure I was getting the most
> > > recent version of the ports, hopefully including a
> > > fix to the chicken-and-egg problem noted in
> > > /usr/ports/UPDATING
> >
> > x11/xorg-clients port does not conflict with any version of xterm.
> > Where do you see that?
>
> For an interesting variation, I have a totally up to date ports tree,
> with the latest versions of xterm and xorg-clients already installed:
>
> xterm-206_1         Terminal emulator for the X Window System
> xorg-clients-6.8.2_1 X client programs and related files from X.Org
>
> then, portupgrade -fp xterm xorg-clients
> ...
> ===>  Installing for xterm-206_1
>
> ===>  xterm-206_1 conflicts with installed package(s):
>       xorg-clients-6.8.2
>
>       They install files into the same place.
>       Please remove them first with pkg_delete(1).
> *** Error code 1
>
> Again, please note that xterm conflicts with the version of the
> clients it is supposed to work with.

this should read "shows a conflict with a version of the port that is 
not installed".

> This is repeatable on 2 systems 
> I have tried so far, 5.4-RELEASE/i386 and 6.0-STABLE/amd64.
>
> A.

-- 
Andy Fawcett                                     | andy@athame.co.uk
                                                 | tap@kde.org
"In an open world without walls and fences,      | tap@lspace.org
  we wouldn't need Windows and Gates."  -- anon  | tap@fruitsalad.org



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200511170014.58776.andy>