Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 21 Nov 2006 13:45:28 -0500
From:      Chuck Swiger <cswiger@mac.com>
To:        Ted Mittelstaedt <tedm@toybox.placo.com>
Cc:        cremes.devlist@mac.com, Lonnie Cumberland <lonnie@outstep.com>, freebsd-questions@freebsd.org
Subject:   Re: MAC OS X connection to FreeBSD?
Message-ID:  <45634948.7040107@mac.com>
In-Reply-To: <002e01c70d5c$f134cc30$3c01a8c0@coolf89ea26645>
References:  <454E9F7B.5010105@outstep.com> <454EB6D6.3030807@infowest.com> <454EBEEC.1060002@u.washington.edu> <454F210C.9000602@outstep.com> <004001c70706$0d571ec0$3c01a8c0@coolf89ea26645> <62104DC1-8AD2-41E1-B469-51CAC91A8D8B@mac.com> <002701c70c85$db821eb0$3c01a8c0@coolf89ea26645> <4561E19B.7050706@mac.com> <002e01c70d5c$f134cc30$3c01a8c0@coolf89ea26645>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Ted Mittelstaedt wrote:
> "Chuck Swiger" <cswiger@mac.com> wrote:
[ ... ]
>>> I spent a lot of time trying to build KDE on Panther and end up at a
>>> dead end.  There's many problems there.
>> That's not a very specific bug report.  It's at least possible that
>> reading this would help:
>>
>> http://developer.apple.com/opensource/tools/runningx11.html
> 
> I read that at the time plus a lot more.  Yes the X11 system was installed.
> If you have never tried building KDE on Panther I suggest you try it.

While I rarely-- very rarely-- have a use for X11 in rootless mode, I wouldn't 
have any desire to run KDE on a system which can run the native OSX GUI.

> This isn't something that a single bug report can take care of.

That's entirely believable, but submitting a Radar to Apple, or filing a bug 
report with the KDE project, is at least a starting point, even if the changed 
required exceed a single bug report.

Something that comes to mind, is that at least some X11 software depends on 
having a case-sensitive filesystem in order to build properly.  If you're 
running into issues involving filename case, trying the build on a UFS 
partition or on the new Journaled/case-sensitive HFS+ option might work better.

If this is an issue which affects KDE, the solution for people building from 
source is probably going to require changes on the part of the KDE project.

[ ... ]
>>> In any case, Tiger won't run on anything that doesen't have firewire
>>> so you can just toss out your older iMacs right there.
>> Apple recommends you run Tiger on G4 or later hardware, but I believe that
>> Tiger will run on G3 hardware if you can get a DVD drive attached.
> 
> Rubbish.  Apple came out with option CD installation of Tiger you could
> send away for, I did and I have it.  A DVD drive is not necessary.  And
> many G3s came with a firewire port and can boot it.  But not all of them
> did and the ones that didn't you cannot boot Tiger on.

Be that as it may, it's generally recognized that a vendor should support 
their hardware and software for at least five years; beyond that, providing 
partial support on a "best-efforts" basis is reasonable.

If you go far enough back to the earliest G3's, they're probably lacking the 
minimal video hardware capabilities to run Tiger, or some such...but at least 
some G3's will run Tiger.

>> Given that the G3 machines came out in what-- 1998?-- the situation is 
>> probably more to Apple's credit than to its detriment.  Frankly, if you
>> need to throw out 8-year-old machines in order to run the latest version
>> of the OS, and you've gotten 8 years of decent utilization out of the
>> hardware during that time, you're way ahead of the typical 3-year
>> depreciation cycle for business PCs.
> 
> Oh ho, so where did the much-vaunted "Mac's retain their resale value
> longer than PC's" go that I used to hear spewed so often?

I don't know, and I'm not interested in digging up old arguments.

(I'm not even that interested in new arguments; I'd prefer to figure out the 
facts and leave debating opinions to others.)

[ ...comments about old hardware... ]

Yes, I've got a fair number of Dell PPros or D300-450's which are still 
providing good value, although the IDE hard drives are becoming sketchy this 
far down the road.  The ones with SCSI (typ. 4GB Seagates, or 9-19GB WD or IBM 
UltraStars) have generally held up quite well.

> So much for the so-called "3 year depreciation cycle for business PC's"
> That's wishful thinking by Microsoft looking for increasing their revenue
> stream, and by "power users" in corporations that want to spend more
> time playing with the latest software doodad on company-supplied hardware
> than doing their jobs.

I was thinking more of the typical 3-year lease terms after which the hardware 
is valued either at FMV or 10% residual, actually.  Well, maybe you don't do 
too much with hosting facilities which lease equipment for their customers.

Anyway, I don't know about Microsoft's intentions, but it wouldn't surprise me 
that they'd rather sell a new license than permit people to recycle older 
ones.  Seems OT for this list, however.

>> Ted, you do know that Win98 & ME simply won't run on modern PCIe
>> motherboards, right? You do know that XP and Vista don't run, or run with
>> extreme compromises to video support and performance, on Pentium-pro
>> machines without AGP or with maybe AGPx1 slots with say, a 4MB Riva128
>> card?
> 
> Do you know the vast majority of business hardware in service
> isn't this advanced?

Sure.  But it's what you're likely get when you buy new hardware today.

And it's not just Win98 that has issues; from what I've seen, it looks like 
plenty of new BIOSes don't set up IRQ routing very well unless the APIC is 
enabled, and that affects older versions of FreeBSD as well.

> You need to read up on the following:
> 
> http://www.microsoft.com/windows/lifecycle/default.mspx
> 
> Win98SE - little under 5 years of support
> Windows 2K - 5 years of support
> Win XP - 7 years of support, and unlimited with Windows Product Activation,
> at least right now.
> Vista - TBA
> 
> In case you didn't realize, thats a linear progression.

Quite right-- I *don't* realize that 5, 5, 7, TBA is a linear progression!

Try plotting (1998, 5), (2000, 5), (XP [2002?], 7), & (2007, TBA) yourself and 
show us what kinda line you get.... :-)

[ ...I don't disagree with your car analogy, but that's also drifting OT... ]
>>>> OSX has excellent support for most UNIX software.
>>> Uh, huh.  Yeah, right.
>> OSX has excellent support for the Unix software I want to run.
> 
> OK, that's better. :-)

Peace in our time?

-- 
-Chuck



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?45634948.7040107>