Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 21 Aug 2020 12:34:55 +0800
From:      Ramces Red <rrtred@airmail.cc>
To:        freebsd-questions@freebsd.org
Subject:   Resolving a dependency conflict when using /usr/ports
Message-ID:  <20200821043455.go2kmiiwdzs2cste@haraya.local.net>

Next in thread | Raw E-Mail | Index | Archive | Help

--5jr6r7kvmx6zns7z
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hello,

I am not quite sure if this is the avenue for this but I was in the
process of trying out FreeBSD and I was having this problem where I have
a dependency conflict while installing the news/atp port:

pkg-static: atp-1.50_2 conflicts with libedit-3.1.20191231,1=20
(installs files into the same place). =20
Problematic file: /usr/local/man/man3/editline.3.gz

Now, as I understood this it seems that there's a conflict with libedit
where atp is also installing stuff in the same place. I tried installing
the pkg version and doing so will basically rip my entire system as it
will remove llvm, vim, among others.

Is there any way to deal with this issue, like changing where stuff are bei=
ng installed
where?

Any help will be appreciated,

Thanks!

Ramces

--5jr6r7kvmx6zns7z
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEE73ZoCiaSkZWHgrHwkrkU2XhsqpMFAl8/TugACgkQkrkU2Xhs
qpPsmwf+MX/EOr6+HTqzB2KVpAhSspvLOsKu/BSxzxrGfWFvREk5hJZIbg9V8snq
O+Zybo5fvDd5OjS4sSrALHrXMOSgmOrKRHmXXWggE7s7gpMOYbQlDjd5vvhGnBL3
k3cSiaZ3POjB+vIEIIlqokZmjdkZv2slNGaH/E756HKsBn+jvb7UGIR5Po+i9Ui+
ba6h6toefNU/gnnljiZ8N6/5+6U7PNAf0PnzyiervoITNMNPHodl6VISn/KmNSmU
hL5rtHXBF3EaS8BecTrok7KIY6oeEZdZdQRbVVnAtLrYFKwQa8LkpPdludsVyEZT
H2tcVdb+62k/J5yjJiJ71CHlTPo0hw==
=EwkC
-----END PGP SIGNATURE-----

--5jr6r7kvmx6zns7z--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200821043455.go2kmiiwdzs2cste>