Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 01 Mar 2012 12:43:58 +0000
From:      Karl Pielorz <kpielorz_lst@tdx.co.uk>
To:        egoitz@ramattack.net
Cc:        freebsd-questions@freebsd.org
Subject:   Re: FreeBSD 9-R pxeboot fails with 'Mounting root filesystem rw  failed'...
Message-ID:  <326A337AEB321D9EDA1AFFF4@OctaHexa64-MkII>
In-Reply-To: <55469.194.30.18.3.1330599220.squirrel@www1.saremail.com>
References:  <0D52CADE287778C263E7EF6A@OctaHexa64-MkII> <55469.194.30.18.3.1330599220.squirrel@www1.saremail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--On 01 March 2012 11:53 +0100 egoitz@ramattack.net wrote:

> So I recomend you reading last mails of mine in freebsd-hackers...
>
> Hope it helps,
> Bye!

For what it's worth - I've resolved the issue I had (which was basically 
the system booted, but failed trying to re-mount root as RW, and hence 
wouldn't go into the installer).

The fix I did was to change the '/etc/fstab' on the Netboot server (i.e. 
the copy of FreeBSD that you're booting).

It contains:

"
/dev/iso9660/FREEBSD_INSTALL / cd9660 ro 0 0
"

Just commenting out that line, i.e.

"
#/dev/iso9660/FREEBSD_INSTALL / cd9660 ro 0 0
"

Means the boot now completes, and I get offered the "Install / Shell / Live 
CD" prompt, instead of an error about not being able to remount root.

I've yet to complete an install this way (so far we're just using a script 
to extract the new 9.x style '.txz' files).

But that little change does let us netboot correctly now, enough for what 
we need.

-Karl



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?326A337AEB321D9EDA1AFFF4>