Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 10 Nov 2015 09:23:04 -0553.75
From:      "William A. Mahaffey III" <wam@hiwaay.net>
To:        FreeBSD Questions !!!! <freebsd-questions@freebsd.org>
Subject:   Re: amd64-gcc question
Message-ID:  <56420A8E.6080409@hiwaay.net>
In-Reply-To: <5640D486.5050305@hiwaay.net>
References:  <5640D486.5050305@hiwaay.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 11/09/15 11:19, William A. Mahaffey III wrote:
>
>
> I pkg-installed amd64-gcc over the weekend hoping for Graphite 
> (auto-loop parallelization) support, but no go. I looked around over 
> the weekend & found that there was no port for that package, only the 
> pkg. I just did a 'portsnap fetch upgrade' & there is now a port for 
> amd64-gcc, but it includes no files & no pkg-descr file. I determined 
> over the weekend that the gcc's from about V4.3 on can indeed be built 
> w/ Graphite support, but you need to do it manually. I found a post 
> dated 2010 from someone who did it under linux: 
> http://openwall.info/wiki/internal/gcc-local-build. I see no configure 
> files for any of the gcc ports (I have the entire ports tree 
> downloaded & local, & freshly updated as of a few min. ago). What is 
> the canonical/BPP (FreeBSD 9.3R) way of recompiling a port with 
> different config flags ?
>
>
> I did find ports/pkgs for the 2 main components apparently needed for 
> Graphite support (cloog & ppl) & pkg-installed them over the weekend, 
> so I am ready to go on that front.
>
>
> I have gotten as far as running 'make showconfig' in the various gcc* 
> & amd64-gcc directories to see what info I could get on default config 
> options. In all cases they gave options & said to run 'make config' to 
> change options. I didn't even see a 'config:' entry in the Makefiles 
> (probably included from elsewhere, but I didn't chase it). I only want 
> to make the minimum # of config mods necessary (trusting that pkg/port 
> maintainers probably know more than I about their various pkg's & 
> ports) to add the cloog & ppl support & recompile.
>
>
> I have been using pkg almost exclusively to maintain my (now 3) 
> FreeBSD 9.3R boxen, except for recompiling the linux-c6 flash plugin 
> for this box whenever it get upgraded, so I have *no* experience with 
> getting more nitty-gritty w/ FreeBSD ports than that :-/. TIA & have a 
> good one.


Well, I plunged ahead by modifying the Makefile for 
/usr/ports/lang/gcc49 to include '--with-ppl=/usr/local/lib 
--with-cloog=/usr/local/lib' in the 'CONFIGURE_ARGS+=' block & kicked 
off a 'make install', with all output collected in a file for perusal & 
posting if necessary. I grepped through for cloog & ominously found no 
occurrences. I tried ppl & found some, so I decided to just go ahead & 
try the compiler on my code. I got the same results as over the weekend:


Beginning background make all
Initiated at 08:58:01 AM MCST on Tuesday, November 10, 2015

gcc49 -DNDEBUG -DUNDER_SCORE_SYS -DLOSE_GAMMAL -I../include -I~/inc 
-I../Properties -I../TEST -I../pre  -march=opteron -mtune=opteron -O3 
-floop-strip-mine -floop-blo
ck -fprefetch-loop-arrays -floop-parallelize-all 
-ftree-parallelize-loops=4 -fopt-info -c mpi.c mpprime.c
mpi.c:1:0: sorry, unimplemented: Graphite loop optimizations cannot be 
used (-fgraphite, -fgraphite-identity, -floop-block, -floop-interchange, 
-floop-strip-mine, -fl
oop-parallelize-all, and -ftree-loop-linear)
  /*
  ^
mpprime.c:1:0: sorry, unimplemented: Graphite loop optimizations cannot 
be used (-fgraphite, -fgraphite-identity, -floop-block, 
-floop-interchange, -floop-strip-mine,
  -floop-parallelize-all, and -ftree-loop-linear)
  /*
  ^
*** [../lib/R4/opteron/libmpi.a] Error code 1
1 error
`usual' not remade because of errors.
gcc49 -DNDEBUG -DUNDER_SCORE_SYS -DLOSE_GAMMAL -I../include -I~/inc 
-I../Properties -I../TEST -I../pre  -DP64_BIT -march=opteron 
-mtune=opteron -O3 -floop-strip-mine
-floop-block -fprefetch-loop-arrays -floop-parallelize-all 
-ftree-parallelize-loops=4 -fopt-info -c mpi.c mpprime.c
mpi.c:1:0: sorry, unimplemented: Graphite loop optimizations cannot be 
used (-fgraphite, -fgraphite-identity, -floop-block, -floop-interchange, 
-floop-strip-mine, -fl
oop-parallelize-all, and -ftree-loop-linear)
  /*
  ^
mpprime.c:1:0: sorry, unimplemented: Graphite loop optimizations cannot 
be used (-fgraphite, -fgraphite-identity, -floop-block, 
-floop-interchange, -floop-strip-mine,
  -floop-parallelize-all, and -ftree-loop-linear)
  /*
  ^
*** [../lib/R8/opteron/libmpi.a] Error code 1
1 error
`usual' not remade because of errors.
MakeMPI: OPTERON up to date.


i.e. no Graphite support. As I said above I have (all of ?) the required 
other ports (cloog & ppl & their dependencies) pkg-installed & ready to 
go. What does a feller have to do to get this to work :-) ? *ANY* clues 
appreciated. TIA & have a good one.


-- 

	William A. Mahaffey III

  ----------------------------------------------------------------------

	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?56420A8E.6080409>