Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 10 Apr 2010 00:12:47 +0200
From:      Michael Beckmann <michael@apfel.de>
To:        pyunyh@gmail.com
Cc:        stable@freebsd.org
Subject:   Re: Realtek Ethernet not functioning on Asus M4A89GTD PRO
Message-ID:  <C5FB6BEDCE679BF318BDDAFA@[10.0.0.102]>
In-Reply-To: <20100409173228.GC1085@michelle.cdnetworks.com>
References:  <!&!AAAAAAAAAAAYAAAAAAAAAFu8E7CkEvBMsgZ/8G4PwcPigAAAEAAAAHlHe9UOq29Hg4tmJB6O8ysBAAAAAA==@apfel.de> <20100409173228.GC1085@michelle.cdnetworks.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
--On Freitag, 9. April 2010 10:32 -0700 Pyun YongHyeon <pyunyh@gmail.com> 
wrote:

> On Fri, Apr 09, 2010 at 01:50:02AM +0200, Michael Beckmann wrote:
>> Greetings,
>>
>> the onboard Realtek Ethernet on my Asus M4A89GTD PRO is not functioning.
>>
>> I use FreeBSD 8.0-STABLE with a generic kernel (amd64). Everything was
>> updated March 27, 2010.
>>
>> Is it a bug?
>>
>> Thanks,
>>
>> Michael
>>
>>
>> pcib4: <ACPI PCI-PCI bridge> at device 21.0 on pci0
>> pci4: <ACPI PCI bus> on pcib4
>> re0: <RealTek
>> 8168/8168B/8168C/8168CP/8168D/8168DP/8111B/8111C/8111CP/8111DP PCIe
>> Gigabit Ethernet> port 0xe800-0xe8ff mem
>> 0xfdfff000-0xfdffffff,0xfdff8000-0xfdffbfff irq 16 at device 0.0 on pci4
>> re0: Using 1 MSI messages
>> re0: Chip rev. 0x2c000000
>> re0: MAC rev. 0x00000000
>> re0: Unknown H/W revision: 0x2c000000
>> device_attach: re0 attach returned 6
>
> Try attached patch and let me know how it goes.

The patch solved the problem. I can now use the Ethernet interface. I will 
report if I find any problems in the long run.

Many thanks!

Michael




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?C5FB6BEDCE679BF318BDDAFA>