Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 01 Mar 2012 19:50:55 +0100
From:      egoitz@ramattack.net
To:        Karl Pielorz <kpielorz_lst@tdx.co.uk>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: FreeBSD 9-R pxeboot fails with 'Mounting root filesystem rw failed'...
Message-ID:  <7037aefa6e807250861702438777767d@ramattack.net>
In-Reply-To: <326A337AEB321D9EDA1AFFF4@OctaHexa64-MkII>
References:  <0D52CADE287778C263E7EF6A@OctaHexa64-MkII> <55469.194.30.18.3.1330599220.squirrel@www1.saremail.com> <326A337AEB321D9EDA1AFFF4@OctaHexa64-MkII>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
In the "new" way of booting... you need to have the cd because the own 
cd is the root filesystem... and in fact is live filesystem too.... so 
unless you're booting from mfsroot... I assume you should have that line 
in /etc/fstab inside the iso image.... but if you're using mfsroot... I 
really even am not creating etc dir inside the iso image... because it's 
not needed and in previous releases and iso images when always booted 
from mfsroot (and where not livefs cds and so) it wasn't necessary...



On Thu, 01 Mar 2012 12:43:58 +0000, Karl Pielorz wrote:
> --On 01 March 2012 11:53 +0100 egoitz@ramattack.net wrote:
>
>> So I recomend you reading last mails of mine in freebsd-hackers...
>>
>> Hope it helps,
>> Bye!
>
> For what it's worth - I've resolved the issue I had (which was
> basically the system booted, but failed trying to re-mount root as 
> RW,
> and hence wouldn't go into the installer).
>
> The fix I did was to change the '/etc/fstab' on the Netboot server
> (i.e. the copy of FreeBSD that you're booting).
>
> It contains:
>
> "
> /dev/iso9660/FREEBSD_INSTALL / cd9660 ro 0 0
> "
>
> Just commenting out that line, i.e.
>
> "
> #/dev/iso9660/FREEBSD_INSTALL / cd9660 ro 0 0
> "
>
> Means the boot now completes, and I get offered the "Install / Shell
> / Live CD" prompt, instead of an error about not being able to 
> remount
> root.
>
> I've yet to complete an install this way (so far we're just using a
> script to extract the new 9.x style '.txz' files).
>
> But that little change does let us netboot correctly now, enough for
> what we need.
>
> -Karl




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?7037aefa6e807250861702438777767d>