Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 19 Jan 2012 09:46:28 -0700
From:      Chad Perrin <perrin@apotheon.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: FreeBSD 9
Message-ID:  <20120119164628.GC21488@hemlock.hydra>
In-Reply-To: <loom.20120119T113323-535@post.gmane.org>
References:  <BLU160-W54C133B8003EF140C41EF7AE860@phx.gbl> <loom.20120119T094302-811@post.gmane.org> <8397.74345881796$1326968162@news.gmane.org> <loom.20120119T113323-535@post.gmane.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Thu, Jan 19, 2012 at 10:41:37AM +0000, inquiz wrote:
> Eduardo Morras <nec556 <at> retena.com> writes:
> 
> > ... 
> > I think that a full/complete update of the old installer to add it 
> > support GEOM, ZFS, scripting and more newer features will consume 
> > more manpower and resources than create a new one from scratch, where 
> > the devs aren't chained by old code, backwards compatibility, old 
> > restrictions and old point of views. This way, is easier correct 
> > bugs, new features, simplify the installation and even automate it to 
> > this new installer than try to add them to the old one.
> > 
> > As always, i suppose that any ideas and help are welcome.
> > ...
> 
> If devs decided that there are good technical and other reasons to retire
> the old installer, then that's fair enough.
> But then the new installer has to be at least equal in features, functionality,
> and overall quality.

. . . or provide the ability to select the old installer at boot time,
perhaps.  Let's not turn this into a false dilemma; I don't see why we
can't have our cake and eat it too for a while.

-- 
Chad Perrin [ original content licensed OWL: http://owl.apotheon.org ]



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20120119164628.GC21488>