Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 25 Jan 2014 00:10:23 -0700 (MST)
From:      Warren Block <wblock@wonkity.com>
To:        Charlie <cwr@SDF.ORG>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Xorg on ThinkPad T430/10.0-RELEASE
Message-ID:  <alpine.BSF.2.00.1401250006590.95135@wonkity.com>
In-Reply-To: <Pine.NEB.4.64.1401250236220.12721@faeroes.freeshell.org>
References:  <Pine.NEB.4.64.1401250236220.12721@faeroes.freeshell.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 25 Jan 2014, Charlie wrote:

> I just did a fresh install of 10.0-RELEASE on my ThinkPad T430 (Intel 
> graphics).
>
> I do not have a display/login manager (such as XDM or GDM, etc.) running on 
> my system, so I do a simple "startx" to launch X and begin my XFCE4 session.
>
> However, when I attempt to exit X and return to the console, the screen goes 
> dark and the usual combination of ctrl + alt + F* does nothing, nor does 
> ctrl-alt-backspace.

Yes.  You are using the KMS video drivers, and currently there is no KMS 
console driver in FreeBSD 10.  There is one, called Newcons, in 
-CURRENT, and an MFC is planned at some point:
https://wiki.freebsd.org/Newcons

> I can still SSH into the laptop, so the system has not crashed, it just seems 
> like its a problem with X and/or the system console.

The console is running, it just can't be seen.  Type startx and you will 
be back in X and can shut down or do further work in a terminal window.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1401250006590.95135>