Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 30 Mar 2013 21:37:22 +0000 (UTC)
From:      Walter Hurry <walterhurry@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: x11-toolkits/gtksourceview2 is broken
Message-ID:  <kj7lui$9nf$1@ger.gmane.org>
References:  <kj4p1f$21t$1@ger.gmane.org> <CAHHBGkqn5CabjzL0gZejmg_qmFPvrND5G0fCAXrfiuYwML6fGw@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, 29 Mar 2013 16:27:20 -0400, illoai@gmail.com wrote:

> On 29 March 2013 15:11, Walter Hurry <walterhurry@gmail.com> wrote:
> 
>> FreeBSD 9.1-RELEASE on amd64
>>
>> This afternoon I upgraded textproc/libxml2 from version 2.7.8_5 to
>> version 2.7.8_0 (at least I think it's libxml2 that's the problem - I
>> upgraded py27-libxml2 and gdk-pixbuf2 at the same time).
>>
>> Then x11-toolkits/gtksourceview2 would not compile. I got the following
>> error:
>>
>>   CCLD   test-widget
>> ../gtksourceview/.libs/libgtksourceview-2.0.so: undefined reference to
>> `xmlTextReaderRelaxNGValidate'
>> gmake[2]: *** [test-widget] Error 1
>>
>> Sure enough, I see a similar error when I try to open a shell script
>> with gedit:
>>
>> /usr/local/lib/libgtksourceview-2.0.so.0: Undefined symbol
>> "xmlTextReaderRelaxNGValidate"
>>
>> Where do I go from here?
>>
>>
 
> Otherwise, you can blindly run # portmaster -r libxml2 (or some
> perverted equivalent thereof)
> & pray.  It'll probably run for a good while.

Didn't help, I'm afraid. Same compilation error on x11-toolkits/
gtksourceview2 - as well as a few others.

The only solution I found was to downgrade libxml2 (and py27-libxml2) 
again.

Can anyone offer advice?




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?kj7lui$9nf$1>