Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 25 Nov 2011 13:02:15 +0100
From:      Moritz Wilhelmy <moritz@wzff.de>
To:        freebsd-questions@freebsd.org
Subject:   Re: No colours at all with ncurses and urxvt on FreeBSD 9.0-RC2
Message-ID:  <20111125120215.GL16096@barfooze.de>
In-Reply-To: <20111125113718.GA4064@debian50-32.invisible-island.net>
References:  <20111125105901.GK16096@barfooze.de> <20111125113718.GA4064@debian50-32.invisible-island.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, Nov 25, 2011 at 06:37:18 -0500, Thomas Dickey wrote:
> On Fri, Nov 25, 2011 at 11:59:01AM +0100, Moritz Wilhelmy wrote:
> > I can't get colours to work with urxvt (the "normal" urxvt, that is, not
> > the 256-color one) over ssh. Google doesn't come up with any usable
> > results for this particular case.. What bothers me is that a termcap
> > entry for "rxvt-unicode" is present on the termcap file FreeBSD came
> > with. I'm really clueless here, can someone give me a hint?
> 
> setting TERM to rxvt-256color looks like the way to fix that issue.

Indeed, setting TERM to either "rxvt-256color" or "rxvt" gives me
colours.  The remaining question is, why doesn't it work with
"rxvt-unicode", which is also in the termcap file?

I'd prefer not working around the issue anymore by conditionally setting
TERM on all my FreeBSD boxes, but fixing it once and for all...

Nevertheless, thanks for your quick reply. Your help is appreciated :-)


Best regards,

Moritz



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20111125120215.GL16096>