Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 24 Aug 1996 10:52:10 -0500 (CDT)
From:      Randy <randyd@nconnect.net>
To:        questions@freebsd.org
Subject:   configuring ccd devices
Message-ID:  <XFMail.960824113708.randyd@nconnect.net>

Next in thread | Raw E-Mail | Index | Archive | Help
Greetings, 
    I seem to be having difficulty understanding how to create ccd
devices and get them up and running.  The man pages (ccd and 
ccdconfig) have failed to help me get it to work. ( I think there is a 
bit of required knowlege it's assumed I have, that I don't yet posess.
Don't you just hate newbies??  :)  )  I'm trying to ccdconfig 2 Conner
80M IDE drives to get a feel for how this works.  If I wreck anything, 
nothing's lost.  I'm able to partition, label, newfs, and mount these 
drives individually, if I wan't to, so I'm pretty sure all is OK hardware-
wise.   I guess what I'm unsure of is the steps required to ccd these
two together.  I've included the "pseudo-device ccd 4" in my kernel
and it shows up on boot-up.  I've created a basic /etc/ccd.conf file.  If
I do a ccdconfig -C -v it says...

    ioctl (CCDIOCSET): /dev/ccd0c: Device not configured

(I also notice this message on boot-up)

I created ccd0 (/dev/MAKEDEV ccd0) and it created ccd0a -ccd0h.  If I
specifically do a MAKEDEV ccd0c it says


    bad unit for disk in ccd0c

If I try to do a ccdconfig ccd0  32  0  /dev/wdc1 /dev/wdc2 it says

   ioctl (CCDIOCSET): /dev/ccd0c: Inappropriate file type or format.


I'm totally lost.  Can anyone help??  

Thanks a lot!!!!


Randy



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?XFMail.960824113708.randyd>