Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 27 Feb 2012 10:26:53 +0100
From:      Ronny Mandal <ronnyma@volatile.no>
To:        freebsd-questions@freebsd.org
Subject:   Re: 9.0, Samba and two NICs
Message-ID:  <CAEduhe--gw226dz2AnaAbHJV8eBhGGFojVES7PTkTE+aQxb76Q@mail.gmail.com>
In-Reply-To: <4F47A295.6020200@herveybayaustralia.com.au>
References:  <CAEduhe-mX9KcEZCFhn_DAzw64YSUz2Uypwr2kK1Mj0qqT9DvXA@mail.gmail.com> <4F47A295.6020200@herveybayaustralia.com.au>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, Feb 24, 2012 at 3:45 PM, Da Rock
<freebsd-questions@herveybayaustralia.com.au> wrote:
> On 02/24/12 21:39, Ronny Mandal wrote:
>>
>> Hi!
>>
>> I have been running Samba on FreeBSD 9.0 with a wireless card. A share
>> is connected to my W7 computer. To get more speed between the
>> computers, I decided to activate the 1GBit- Ethernet on the FreeBSD
>> and establish a direct connection (cross-link) to the W7. I gave the
>> new connection a static IP/subnet: 10.0.0.2/255.0.0.0 for the FreeBSD
>> and 10.0.0.1/255.0.0.0 for the W7. SSH works fine, however Samba is
>> utilizing the wireless card.
>>
>> My smb.conf looks something like this:
>>
>> ..
>> ;The 192-address is the wireless, ath0. 10.0.0.2 is age0
>> interfaces = 127.0.0.1 192.168.0.232 10.0.0.2
>> bind interfaces only = yes
>> ; the two latter is the IPs of the W7
>> hosts allow = 127.0.0.1 192.168.0.117 10.0.0.1
>>
>>
>> If I remove the 192* in the hosts allow, my W7 looses access via smb.
>>
>> netstat tells me that it is listening to both interfaces.
>>
>> What might be wrong?
>
> What address is the w7 using?
>
> If it is using 192.X, that could be the problem. That or some variation...
> such as the w7 using wireless and 192.x?

Sorry about the late answer and missing info. The W7 is using both,
i.e. wireless and wired.

Strangely enough, it works now. Here is what I did:

The interface parameter; I put the 10.* before the 192.* and stopped
and started the samba-service. After that, the wired card were
utilized when I copied to and from the share.

interfaces = 192.168.0.232 10.0.0.2 127.0.0.1 changed to interfaces =
10.0.0.2 192.168.0.232 127.0.0.1

(I tried this earlier, but it seems that /usr/local/etc/rc.d/samba
restart did not properly re-read the configuration.)


Regards,

Ronny Mandal



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAEduhe--gw226dz2AnaAbHJV8eBhGGFojVES7PTkTE+aQxb76Q>