Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 25 Jul 2007 00:16:24 -0700
From:      "Michael S. Eubanks" <mse_software@charter.net>
To:        freebsd-questions@freebsd.org
Cc:        Terry Todd <tlt@badger.tltodd.com>
Subject:   Re: ssh X11 forwarding not working on FreeBSD 6.2
Message-ID:  <1185347784.8728.27.camel@yak.mseubanks.net>
In-Reply-To: <20070724132925.A36540@badger.tltodd.com>
References:  <20070724105922.A29729@badger.tltodd.com> <1185295685.2034.4.camel@yak.mseubanks.net> <20070724122340.A32857@badger.tltodd.com> <1185299662.2034.9.camel@yak.mseubanks.net> <20070724132925.A36540@badger.tltodd.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, 2007-07-24 at 13:29 -0500, Terry Todd wrote:
> On Tue, Jul 24, 2007 at 10:54:22AM -0700, Michael S. Eubanks wrote:
> ...
> > Question.  How many X servers do you have running?  Are you logged into
> > a window manager when you are attempting to connect?
> > 
> 
> Only one instance of Xming is running on the Windows XP system.
> I am using PuTTY to connect to the FreeBSD system and the other
> systems.  The other systems all work.  FreeBSD X11 forwarding does
> not work.  It is an off the shelf standard install of 6.2.
> 
> Manually setting the DISPLAY variable on the FreeBSD system to
> [IP address of Widows XP system]:0.0 will allow it to work but
> that's not what I want to do here.  I want it to automatically
> forward the X11 session through ssh like it does when connecting
> to the FC6 system.
> 
> Terry Todd
> 

Okay.  I was able to get it running.  I received a slightly different
error when I tried running an application the first time.  My error is
from Xming and displays as follows (using X forwarding):

AUDIT: Tue Jul 24 23:47:34 2007: 608 C:\Program Files\Xming\xming.exe
client 4 rejected from IP 192.168.10.101

This error simply means to add the ``-ac'' option to the Xming desktop
shortcut.  Let me walk you through what I did.  Before I begin, I'm
using 6-STABLE (now on 6.2) with Xorg 7.2.


QUICK INSTRUCTIONS
1.  Make sure to install Xming using both the Xming installer program
and Xming fonts installer.

2.  Modify the Desktop Xming shortcut to include the following
arguments:  ``:0 -clipboard -multiwindow -ac''.  The ac option accepts
client requests and quells the error that I had above.

3.  Start Xming using the shortcut you just created

4.  I'm going to guess that you may leave your sshd_config file the way
it is - I did.

5.  Install the Xming Portable PuTTY package.  Make the changes shown to
the PuTTY configuration as shown here before you connect to the FreeBSD
machine (NOTE the X11 forwarding to localhost:0 - I think this is how
you said your config was):

http://www.straightrunning.com/XmingNotes/trouble.php

6.  Log into the FreeBSD machine using PuTTY.  Set the DISPLAY
environment variable equal to the IP address and display of the XP
machine.  The command I used was:

export DISPLAY=192.168.xxx.xxx:0

7.  Make sure your Windows Firewall is either turned off or allows
incoming requests for Xming.

8.  Execute a command like xeyes.  It should show on the windows
desktop.


> 
> On Tue, Jul 24, 2007 at 10:54:22AM -0700, Michael S. Eubanks wrote:
> > On Tue, 2007-07-24 at 12:23 -0500, Terry Todd wrote:
> > > On Tue, Jul 24, 2007 at 09:48:05AM -0700, Michael S. Eubanks wrote:
> > > ...
> > > > Start by changing the following line from
> > > >
> > > > X11DisplayOffset 10
> > > >
> > > > to
> > > >  
> > > > X11DisplayOffset 1
> > > ...
> > > 
> > > OK, I tried that.  No difference.
> > > 
> > > Here's what heppened on the FreeBSD 6.2 system:
> > > $
> > > $ echo $DISPLAY
> > > localhost:1.0
> > > $
> > > $ xhost
> > > Xlib: connection to "localhost:1.0" refused by server
> > > Xlib: PuTTY X11 proxy: wrong authentication protocol attempted
> > > xhost:  unable to open display "localhost:1.0"
> > > $
> > > $ xhost +
> > > Xlib: connection to "localhost:1.0" refused by server
> > > Xlib: PuTTY X11 proxy: wrong authentication protocol attempted
> > > xhost:  unable to open display "localhost:1.0"
> > > $ xterm
> > > Xlib: connection to "localhost:1.0" refused by server
> > > Xlib: PuTTY X11 proxy: wrong authentication protocol attempted
> > > xterm Xt error: Can't open display: localhost:1.0
> > > $
> > 
> > Question.  How many X servers do you have running?  Are you logged into
> > a window manager when you are attempting to connect?
> > 
> > 
> > > 
> > > 
> > > 
> > > Here's what happens on the FC6 system:
> > > $ echo $DISPLAY
> > > localhost:13.0
> > > $
> > > $ xhost
> > > access control disabled, clients can connect from any host
> > > INET:terry-pc.egizone.com
> > > LOCAL:
> > > $
> > > 
> > > Terry Todd
> > > 
> > > 
> > > On Tue, Jul 24, 2007 at 09:48:05AM -0700, Michael S. Eubanks wrote:
> > > > On Tue, 2007-07-24 at 10:59 -0500, Terry Todd wrote:
> > > > > I have installed Xming successfully on a Windows XP system. 
> > > > > It works OK to a FC6 system and an older UNIXware system. 
> > > > >  
> > > > > However when trying to connect to a FreeBSD 6.2 system with PuTTY
> > > > > ssh it doesn't work.  PuTTY has Enable X11 forwarding checked.
> > > > >  
> > > > > Here's what I get: 
> > > > >  
> > > > > $ 
> > > > > $ xhost 
> > > > > Xlib: connection to "localhost:10.0" refused by server 
> > > > > Xlib: PuTTY X11 proxy: wrong authentication protocol attempted 
> > > > > xhost: unable to open display "localhost:10.0" 
> > > > > $ 
> > > > >  
> > > > > What can be wrong? 
> > > > >  
> > > > > I have ssh configured as follows: 
> > > > > # grep X11 /etc/ssh/* 
> > > > > /etc/ssh/ssh_config:ForwardX11 yes 
> > > > > /etc/ssh/ssh_config:ForwardX11Trusted yes 
> > > > > /etc/ssh/sshd_config:X11Forwarding yes 
> > > > > /etc/ssh/sshd_config:X11DisplayOffset 10 
> > > > > /etc/ssh/sshd_config:X11UseLocalhost yes 
> > > > >  
> > > > 
> > > > Start by changing the following line from
> > > > 
> > > > X11DisplayOffset 10
> > > > 
> > > > to
> > > > 
> > > > X11DisplayOffset 1
> > > > 
> > > > According to the sshd_conf man page, looks like the number should be set
> > > > to the display that you want to forward (the first available display).
> > > > 
> > > > 
> > > > > Here is the Xming log file: 
> > > > > Welcome to the Xming X Server 
> > > > > Vendor: Colin Harrison 
> > > > > Release: 6.9.0.24 
> > > > > FreeType2: 2.3.0 
> > > > > Contact: http://sourceforge.net/forum/?group_id=156984 
> > > > > 
> > > > > C:\Program Files\Xming\Xming.exe :0 -ac -clipboard -multiwindow  
> > > > >  
> > > > > XdmcpRegisterConnection: newAddress x.x.x.x 
> > > > > winPrefsLoadPreferences: C:\Program Files\Xming\Xmingrc 
> > > > > LoadPreferences: Done parsing the configuration file... 
> > > > > winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel 
> > > > > winAllocateFBShadowGDI - Creating DIB with width: 1600 height: 1200 depth: 32 
> > > > > winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32 
> > > > > glWinInitVisuals:1511: glWinInitVisuals 
> > > > > init_visuals:1055: init_visuals 
> > > > > null screen fn ReparentWindow 
> > > > > null screen fn RestackWindow 
> > > > > InitQueue - Calling pthread_mutex_init 
> > > > > InitQueue - pthread_mutex_init returned 
> > > > > InitQueue - Calling pthread_cond_init 
> > > > > InitQueue - pthread_cond_init returned 
> > > > > winInitMultiWindowWM - Hello 
> > > > > winInitMultiWindowWM - Calling pthread_mutex_lock () 
> > > > > winMultiWindowXMsgProc - Hello 
> > > > > winMultiWindowXMsgProc - Calling pthread_mutex_lock () 
> > > > > glWinScreenProbe:1390: glWinScreenProbe 
> > > > > fixup_visuals:1303: fixup_visuals 
> > > > > init_screen_visuals:1336: init_screen_visuals 
> > > > > (--) 5 mouse buttons found 
> > > > > (--) Setting autorepeat to delay=500, rate=31 
> > > > > (--) winConfigKeyboard - Layout: "00000409" (00000409)  
> > > > > (--) Using preset keyboard for "English (USA)" (409), type "4" 
> > > > > Could not init font path element C:\Program Files\Xming/fonts/misc/, removing from list! 
> > > > > Could not init font path element C:\Program Files\Xming/fonts/TTF/, removing from list! 
> > > > > Could not init font path element C:\Program Files\Xming/fonts/Type1/, removing from list! 
> > > > > Could not init font path element C:\Program Files\Xming/fonts/75dpi/, removing from list! 
> > > > > Could not init font path element C:\Program Files\Xming/fonts/100dpi/, removing from list! 
> > > > > Could not init font path element C:\Program Files\Xming\fonts\dejavu, removing from list! 
> > > > > Could not init font path element C:\Program Files\Xming\fonts\cyrillic, removing from list! 
> > > > > Could not init font path element C:\WINDOWS\Fonts, removing from list! 
> > > > > winInitMultiWindowWM - pthread_mutex_lock () returned. 
> > > > > winInitMultiWindowWM - pthread_mutex_unlock () returned. 
> > > > > winMultiWindowXMsgProc - pthread_mutex_lock () returned. 
> > > > > winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0 
> > > > > winMultiWindowXMsgProc - pthread_mutex_unlock () returned. 
> > > > > winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0 
> > > > > winProcEstablishConnection - Hello 
> > > > > winInitClipboard () 
> > > > > winProcEstablishConnection - winInitClipboard returned. 
> > > > > winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the display. 
> > > > > winClipboardProc - Hello 
> > > > > DetectUnicodeSupport - Windows XP 
> > > > > winClipboardProc - DISPLAY=127.0.0.1:0.0 
> > > > > winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the display. 
> > > > > winClipboardProc - XOpenDisplay () returned and successfully opened the display. 
> > > > >  
> > > > > 
> > > > > Here is the PuTTY event log: 
> > > > > 2007-07-24 09:53:57 Looking up host "x.x.x.x" 
> > > > > 2007-07-24 09:53:57 Connecting to x.x.x.x port 22 
> > > > > 2007-07-24 09:53:57 Server version: SSH-2.0-OpenSSH_4.5p1 FreeBSD-20061110 
> > > > > 2007-07-24 09:53:57 We claim version: SSH-2.0-PuTTY_Snapshot_2005_05_03:r5737 
> > > > > 2007-07-24 09:53:57 Using SSH protocol version 2 
> > > > > 2007-07-24 09:53:57 Doing Diffie-Hellman group exchange 
> > > > > 2007-07-24 09:53:57 Doing Diffie-Hellman key exchange 
> > > > > 2007-07-24 09:53:57 Host key fingerprint is: 
> > > > > 2007-07-24 09:53:57 ssh-dss 1024 06:2a:c4:9c:e7:6a:f8:0d:5a:17:e9:b0:e3:79:1c:a5 
> > > > > 2007-07-24 09:53:57 Initialised AES-256 SDCTR client->server encryption 
> > > > > 2007-07-24 09:53:57 Initialised HMAC-SHA1 client->server MAC algorithm 
> > > > > 2007-07-24 09:53:57 Initialised AES-256 SDCTR server->client encryption 
> > > > > 2007-07-24 09:53:57 Initialised HMAC-SHA1 server->client MAC algorithm 
> > > > > 2007-07-24 09:54:06 Access granted 
> > > > > 2007-07-24 09:54:06 Opened channel for session 
> > > > > 2007-07-24 09:54:06 Requesting X11 forwarding 
> > > > > 2007-07-24 09:54:06 X11 forwarding enabled 
> > > > > 2007-07-24 09:54:06 Allocated pty (ospeed 38400bps, ispeed 38400bps) 
> > > > > 2007-07-24 09:54:06 Started a shell/command 
> > > > > 2007-07-24 09:54:17 Received X11 connect request from 127.0.0.1:53737 
> > > > > 2007-07-24 09:54:17 Opening X11 forward connection succeeded 
> > > > > 2007-07-24 09:54:17 Forwarded X11 connection terminated 
> > > > >  
> > > > 
> > > > 
> > > > -Michael S. Eubanks
> > > >  mse_software@charter.net
> > > > 
> > 
> > -Michael S. Eubanks
> >  mse_software@charter.net
> > 
> > 
> > 
> > _______________________________________________
> > freebsd-questions@freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> > To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1185347784.8728.27.camel>