Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 4 Mar 2011 23:10:12 +0100
From:      Polytropon <freebsd@edvax.de>
To:        Doug Hardie <bc979@lafn.org>
Cc:        FreeBSD Questions <questions@freebsd.org>
Subject:   Re: Purchased Binaries
Message-ID:  <20110304231012.7b45286f.freebsd@edvax.de>
In-Reply-To: <5F4DD89C-5F3B-46B8-BA91-A25B8BF11EEB@lafn.org>
References:  <5F4DD89C-5F3B-46B8-BA91-A25B8BF11EEB@lafn.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, 4 Mar 2011 13:24:32 -0800, Doug Hardie <bc979@lafn.org> wrote:
> I have a client who has purchased some software.  I don't know
> anything much about it yet other than it claims to run on Debian
> and CentOS.  I suspect its binaries.  I will have access to
> things like the developer, name etc. on Monday.  However, thats
> when he needs to know if I can make it run on FreeBSD. I am not
> convinced I want to run production software on the Linux
> compatibility suite. 

FreeBSD itself offers a Linux ABI - an alternative binary
interface. Maybe you'll need additional libraries or programs
that are provided by linux-* ports.



> No good reason other than it sounds like its adding a lot more
> opportunities for breakage. 

It's often said that FreeBSD's Linux ABI runs Linux programs
faster and better than pure Linux, but as I don't use Linux
programs on my FreeBSD systems, I can't be more specific on
this claim.



> This has to be an always up application.  I have virtually
> no knowledge of CentOS other than it was installed on one
> server when I got it.  Any chance those binaries might work
> on FreeBSD? 

That's really hard to estimate without further knowledge. You
should at least TRY to run the application in question and see
if it brings up further requirements or problems, and upon
that experience, make further decisions.



> I am planning on starting with FreeBSD 8.2 since its just out
> and working fine on one of my servers, but could use an earlier
> version if required to make this stuff run. 

It shouldn't be neccessary to use older versions of FreeBSD.
However you can install the COMPAT[4567] components (kernel
settings and ports) to provide that level of OS access if it
should be required.




-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20110304231012.7b45286f.freebsd>