Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 27 Aug 2011 09:21:11 -0700
From:      Paul Beard <paulbeard@gmail.com>
To:        "freebsd-questions@FreeBSD. ORG" <freebsd-questions@freebsd.org>
Subject:   wireless access point in FreeBSD 8.2p2
Message-ID:  <51754C95-3688-4B33-BD98-7DED5F28DC0E@gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
I seem to be missing something, possibly from reading too many HOWTOs. =
What I am trying to do is get a system with a wireless card to stand in =
as a wireless AP should my aging LinkSys base station develop a tragic =
smoke leak.=20

It's an ath0-based card and the following steps suggest it should work =
(it has HOSTAP capabilities and offering robust encryption).=20

ifconfig wlan0 create wlandev ath0
ifconfig wlan0 list caps
=
drivercaps=3D6f85ed41<STA,FF,IBSS,HOSTAP,AHDEMO,TXPMGT,SHSLOT,SHPREAMBLE,M=
ONITOR,MBSS,WPA1,WPA2,BURST,WME,WDS,BGSCAN,TXFRAG>
cryptocaps=3Df<WEP,TKIP,AES,AES_CCM>

But various permutations of rc.conf, hostap.conf and many iterations of =
/etc/rc.c/netif restart leave me with two ifconfig entries, one of the =
ath0 interface and one for wlan0. None of the examples show this so I =
suspect it's wrong. The IP address is pingable from the host it's =
installed in but not from anywhere else. And I can see the AP from =
another system and attach to it but it doesn't route any traffic.=20

from /etc/rc.conf:=20
wlans_ath0=3D"wlan0"
create_args_wlan0=3D"wlanmode hostap"
ifconfig_wlan0=3D"inet 192.168.0.26 netmask 255.255.255.0 ssid lower =
mode 11g channel 8"

from hostap.conf:=20
interface=3Dwlan0
debug=3D1
ctrl_interface=3D/var/run/hostapd
ctrl_interface_group=3Dwheel
ssid=3Dlower
wpa=3D0

redacted results of ifconfig:=20
ath0: flags=3D8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu =
2290
	ether 00:0d:88:93:21:3a
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g =
<hostap>
	status: running

wlan0: flags=3D8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu =
1500
	ether 00:0d:88:93:21:3a
	inet 192.168.0.26 netmask 0xffffff00 broadcast 192.168.0.255
	inet6 fe80::20d:88ff:fe93:213a%wlan0 prefixlen 64 scopeid 0x7=20
	nd6 options=3D3<PERFORMNUD,ACCEPT_RTADV>
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g =
<hostap>
	status: running
	ssid lower channel 8 (2447 MHz 11g) bssid 00:0d:88:93:21:3a
	regdomain FCC indoor ecm authmode AUTO privacy OFF txpower 27
	scanvalid 60 protmode CTS wme burst dtimperiod 1 -dfs

Yes, I am trying it without any encryption until I see some packets =
being passed.=20

It seems like a lot of people are getting this to work but I'm not able =
to follow how they did it.=20
--
Paul Beard

Are you trying to win an argument or solve a problem?=20




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?51754C95-3688-4B33-BD98-7DED5F28DC0E>