Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 09 Aug 2007 08:39:20 +0200
From:      Ingeborg Hellemo <Ingeborg.Hellemo@cc.uit.no>
To:        freebsd-questions@freebsd.org, freebsd-scsi@freebsd.org
Subject:   Qlogic FC-card can't find disk on SATAbeast
Message-ID:  <200708090639.l796dKLJ073662@barnetv.cc.uit.no>

Next in thread | Raw E-Mail | Index | Archive | Help
(This SAN-stuff is one of my weak subjects, so please excuse me if I use the 
wrong terms. If there is a better list to ask this question, please tell me.)


HW: ProLiant DL380 G4
OS: FreeBSD 6.2-RELEASE-p7
FC-card: 
isp0: <Qlogic ISP 2312 PCI FC-AL Adapter> port 0x5000-0x50ff mem 
0xfdff0000-0xfdff0fff irq 97 at device 1.0 on pci10

~/#kldstat
Id Refs Address    Size     Name
 1    9 0xc0400000 7261f4   kernel
 2    1 0xc0b27000 93040    ispfw.ko
 3    1 0xc0bbb000 59f20    acpi.ko
 4    1 0xc6dea000 16000    linux.ko



I am trying to access a disk-device on a SATABeast, but no success:

~/#camcontrol rescan all
Re-scan of bus 0 was successful
Re-scan of bus 1 was successful
Re-scan of bus 2 was successful
Re-scan of bus 3 was successful

~/#camcontrol devlist -v
scbus0 on ciss0 bus 0:
<COMPAQ RAID 1  VOLUME OK>         at scbus0 target 0 lun 0 (pass0,da0)
scbus1 on ciss0 bus 32:
scbus2 on ciss0 bus 33:
scbus3 on isp0 bus 0:
<  >                               at scbus3 target -1 lun -1 ()
scbus-1 on xpt0 bus 0:
<  >                               at scbus-1 target -1 lun -1 (xpt0)


If we try to connect the fibre to our HP EVA SAN the disk shows up after a 
'rescan all' which makes me believe that I have not done any major screw-ups 
in configuring the card.

I can see the device and LUN-number if I enter the cards BIOS, but not from 
FreeBSD. We have tried changing disk-size and LUN-number on the Beast.


Any ideas?



-- 
Ingeborg Østrem Hellemo  --  ingeborg@cc.uit.no  (Univ. of Tromsø, Norway)





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200708090639.l796dKLJ073662>