Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 4 Oct 2006 20:34:18 +0100
From:      Chris <phatfish@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   CDROM read(?) errors during CD boot.
Message-ID:  <718eeb340610041234v64022c6eu18b644abd59feb86@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello,

I get a strange error when booting from my custom boot CD. I'm booting an
encrypted system, just a GENERIC kernel and a fstab file are on the CD. The
whole time i was building and testing the system i kept getting this CDROM
error right near the end of the boot process. It doesn't stop the root file
system being mounted, the system continues to boot ok. It just hangs at bit
while those errors are printed to the console.

If anyone knows what causes it it would be interested to know, i don't see
this behavior in the FreeBSD install Cd's, or other live BSD Cd's. The
penultimate line of the following dmesg illustrates the problem.

Thanks

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
FreeBSD 6.1-RELEASE #0: Sun May  7 04:32:43 UTC 2006
    root@opus.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) XP 2000+ (1659.53-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x662  Stepping = 2

Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
  AMD Features=0xc0400800<SYSCALL,MMX+,3DNow+,3DNow>
real memory  = 234815488 (223 MB)
avail memory = 220266496 (210 MB)
ACPI APIC Table: <KM400A AWRDACPI>
ioapic0 <Version 0.3> irqs 0-23 on motherboard
acpi0: <KM400A AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8235/8237 (Apollo KM400/KM400A) host to PCI bridge> mem
0xe0000000-0xe3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
re0: <Linksys EG1032 (RTL8169S) Gigabit Ethernet> port 0xc000-0xc0ff mem
0xeb000000-0xeb0000ff irq 16 at device 8.0 on pci0
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S media interface> on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
re0: Ethernet address: 00:14:bf:59:be:84
re1: <Linksys EG1032 (RTL8169S) Gigabit Ethernet> port 0xc400-0xc4ff mem
0xeb001000-0xeb0010ff irq 17 at device 9.0 on pci0
miibus1: <MII bus> on re1
rgephy1: <RTL8169S/8110S media interface> on miibus1
rgephy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
re1: Ethernet address: 00:14:bf:59:be:8b
re2: <Linksys EG1032 (RTL8169S) Gigabit Ethernet> port 0xc800-0xc8ff mem
0xeb002000-0xeb0020ff irq 18 at device 10.0 on pci0
miibus2: <MII bus> on re2
rgephy2: <RTL8169S/8110S media interface> on miibus2
rgephy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
re2: Ethernet address: 00:14:bf:59:c1:26
uhci0: <VIA 83C572 USB controller> port 0xcc00-0xcc1f irq 21 at device
16.0on pci0
uhci0: [GIANT-LOCKED]
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xd000-0xd01f irq 21 at device
16.1on pci0
uhci1: [GIANT-LOCKED]
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0xd400-0xd41f irq 21 at device
16.2on pci0
uhci2: [GIANT-LOCKED]
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0: <VIA VT6202 USB 2.0 controller> mem 0xeb003000-0xeb0030ff irq 21 at
device 16.3 on pci0
ehci0: [GIANT-LOCKED]
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <VIA VT6202 USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 8235 UDMA133 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xd800-0xd80f at device 17.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
vr0: <VIA VT6102 Rhine II 10/100BaseTX> port 0xe000-0xe0ff mem
0xeb004000-0xeb0040ff irq 23 at device 18.0 on pci0
miibus3: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> on miibus3
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr0: Ethernet address: 00:11:d8:a1:22:13
acpi_tz0: <Thermal Zone> on acpi0
fdc0: <floppy drive controller> port 0x3f2-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 drq 3
on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1659532379 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 38166MB <Seagate ST340015A 3.01> at ata0-master UDMA100
GEOM_MIRROR: Device gm0 created (id=2698280315).ad1: 38166MB <Seagate
ST340015A 3.01> at ata0-slave UDMA100
GEOM_MIRROR: Device gm0: provider ad0 detected.
GEOM_MIRROR: Device gm0: provider ad1 detected.
GEOM_MIRROR: Device gm0: provider ad1 activated.
GEOM_MIRROR: Device gm0: provider ad0 activated.
GEOM_MIRROR: Device gm0: provider mirror/gm0 launched.
Enter passphrase for mirror/gm0:
GEOM_ELI: Device mirror/gm0.eli created.
GEOM_ELI:     Cipher: AES
GEOM_ELI: Key length: 256
GEOM_ELI:     Crypto: software
acd0: CDROM <ATAPI-CD ROM-DRIVE-52MAX/VER 52CA> at ata1-master UDMA33
acd0: FAILURE - READ_BIG ILLEGAL REQUEST asc=0x64 ascq=0x00 acd0: FAILURE -
READ_BIG ILLEGAL REQUEST asc=0x64 ascq=0x00 acd0: FAILURE - READ_BIG ILLEGAL
REQUEST asc=0x64 ascq=0x00 acd0: FAILURE - READ_BIG ILLEGAL REQUEST asc=0x64
ascq=0x00
Trying to mount root from ufs:/dev/mirror/gm0.elia



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?718eeb340610041234v64022c6eu18b644abd59feb86>